summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 07:33:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 08:47:04 +0200
commitc0bf10a5d714875b9cc8745a97ec7c2983a876e8 (patch)
tree24405c9475056b35da57e76065f500f0975f0a59 /app-admin/awscli
parentdev-python/boto3: Bump to 1.23.5 (diff)
downloadgentoo-c0bf10a5d714875b9cc8745a97ec7c2983a876e8.tar.gz
gentoo-c0bf10a5d714875b9cc8745a97ec7c2983a876e8.tar.bz2
gentoo-c0bf10a5d714875b9cc8745a97ec7c2983a876e8.zip
app-admin/awscli: Bump to 1.24.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.24.5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 48a1e5361ffd..6e056d284caf 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.24.1.gh.tar.gz 2213336 BLAKE2B 2d442ac650b524c8b52be2288aefa76693
DIST aws-cli-1.24.2.gh.tar.gz 2214514 BLAKE2B 93c2e58377f302435c078a0ad4a8b3f465631965633ce51a2993ce57152026b99eb9599620c1400ced0ddd6d1024258d93dca3c4f3bfa3a6f59c3ff56a98a897 SHA512 5f58967714c1285ca065e90aa567370c3b3b11619e812fa271aaeb1e1c5af55a2388fadcccc441a808e6cf73275c3cffbba86699dc4cbd86f09fbcf20c7f1734
DIST aws-cli-1.24.3.gh.tar.gz 2215539 BLAKE2B b571cac95eed696dd3a9242d8291d42ab9c66d192bf090c8df02cdccfe2ab84bdbf73fa145d9ca30cdf3313f39c5b66a931bf5aa3745ad56202aaff787b827d8 SHA512 e9eadd4e82d3fe56eb227eff0fa6bb0080755f4f7ae4219340c73dabbca5b6e6256bdd3a9ff116878becd47e7a245752ad6ea25c7908d9429c41a12b14ab2c59
DIST aws-cli-1.24.4.gh.tar.gz 2215845 BLAKE2B 9b95b53feba4d61e44276c7ee1587a45f91d4171ba102327bb23b308b801a7322873a8e48e420c66a72123fa6ed3e49f54d8d63eaac638d1bd0f80d27a9f1013 SHA512 345e6fc02c04e6a1c2635a29e4c2a00a2ba14ccf2f1de6167ac8113a05cee01b33add850b4bf95ce9ca22449101c0b49993841097d4d3bc7836ca9fd9f80748d
+DIST aws-cli-1.24.5.gh.tar.gz 2215786 BLAKE2B db9077cfe3cf561109dea9ce1395f9d5bbe25b9dd28675e20d56c1fee3ad17e4befdce61cb81f217bb32d85b326ca4069f97482b9670f9653a850fd90fd135f7 SHA512 1cb4fcf37ccc6e7c3dfb211a9bc6687172f4052c6dae307e1a8451947078794973a3fd8382824ca2be650ee5b898b1f8d9bc27e2b403a2c51fea17b319bd366d
diff --git a/app-admin/awscli/awscli-1.24.5.ebuild b/app-admin/awscli/awscli-1.24.5.ebuild
new file mode 100644
index 000000000000..acabee851193
--- /dev/null
+++ b/app-admin/awscli/awscli-1.24.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}