summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-20 09:11:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-20 09:47:09 +0200
commitd1701274cda31922f9acf06c7186ba1a232de543 (patch)
treed5a332f25de37975411e2407db38af5cb58fe7f0 /app-admin/awscli
parentdev-python/boto3: Bump to 1.21.43 (diff)
downloadgentoo-d1701274cda31922f9acf06c7186ba1a232de543.tar.gz
gentoo-d1701274cda31922f9acf06c7186ba1a232de543.tar.bz2
gentoo-d1701274cda31922f9acf06c7186ba1a232de543.zip
app-admin/awscli: Bump to 1.22.98
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.98.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index e58991434bf1..c6fe48cba10e 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -8,3 +8,4 @@ DIST awscli-1.22.93.tar.gz 2187925 BLAKE2B c4b13aada04aea6b320c9b93c83cce11a4081
DIST awscli-1.22.94.tar.gz 2194607 BLAKE2B 985ce46ac8c3a12abc983fda4d424dbfa5c5da26c5552af9895079bc1aaa925e7f0c35f469f6b7f917007e162ce340adc68e4ae1c79f72c673bdf965ee550cfa SHA512 d34ad97d50de64591f0239de94b81d2ab77f8f4e284a356abe684bcd4c4d8f4a2d5e47d67e7b59322898d4f5b3503991eb550a424f894001aec547fe07e58923
DIST awscli-1.22.96.tar.gz 2195648 BLAKE2B 57793e65d63151b150015ef90784140a9d473618849500d81bcb94582c5bc7a66b52337148b3f5c4c6b7196d2ab302fa0592dda3d83f2ff3d4fe845d687d18cf SHA512 71fb2bbc3586868566996cb807d01e582d181d96e52754c7052fc93040124ac7a73813f10fb1b660458772155aaa4f0a4294a583d429717e0bf1f6b785f5b963
DIST awscli-1.22.97.tar.gz 2193983 BLAKE2B f2e0efbb2332d4c405d5e97ba35426424d932a013114492890018d3419349e23aa3c8301f6c29bd8eaa662145b07ceaa30c22e41aad38012ca307400075600ca SHA512 00426aab19fcdf3241850b09d4d5dd6a1460e3ec9baa37cf203068dc6ca0fddd4fe3de7e4e93e8e6539608351777e00692bb8b9d2c362ceeacc55071cd53f422
+DIST awscli-1.22.98.tar.gz 2195040 BLAKE2B 08af6d73a9a719d358bbe60f0d7194ff80c2574d9ca4fb5f3ba0d050a63773aa97077784434f89d502aabe6b67c2aa328e9d291c0204038789f59fd78b8b4965 SHA512 2522e6b0f1b8fca8974ab06d69863b2a286c42e4d0b8939c6580b945beae1bc9d74f65f1de714c46ef4bb1ad154d4cbf37e88b05458961cd6bf6953474358b60
diff --git a/app-admin/awscli/awscli-1.22.98.ebuild b/app-admin/awscli/awscli-1.22.98.ebuild
new file mode 100644
index 000000000000..2040c8cb81d2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.98.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}