summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-30 13:36:02 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-30 13:46:57 +0200
commit87318b1cde334275d51b80790b476f4cc8159242 (patch)
treeb3f8a42fd80462a4d886d5f92932287c4ddb9961 /app-admin/chroot_safe
parentdev-libs/shhopt: EAPI7 revbump, improve ebuild (diff)
downloadgentoo-87318b1cde334275d51b80790b476f4cc8159242.tar.gz
gentoo-87318b1cde334275d51b80790b476f4cc8159242.tar.bz2
gentoo-87318b1cde334275d51b80790b476f4cc8159242.zip
app-admin/chroot_safe: EAPI7 revbump, improve ebuild
Closes: https://bugs.gentoo.org/667358 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/10022
Diffstat (limited to 'app-admin/chroot_safe')
-rw-r--r--app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild b/app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild
new file mode 100644
index 000000000000..1eb04bd3ccbc
--- /dev/null
+++ b/app-admin/chroot_safe/chroot_safe-1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Chroot any dynamically linked application in a safe and sane manner"
+HOMEPAGE="http://chrootsafe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN//_}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_compile() {
+ emake CPPFLAGS="${CXXFLAGS}" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dolib.so chroot_safe.so
+ dosbin chroot_safe
+ sed -i -e "s:/chroot_safe::" "${ED}"/usr/sbin/chroot_safe \
+ || die "sed chroot_safe failed"
+ doman chroot_safe.1
+ dodoc CHANGES.txt
+}