summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-05-19 11:51:39 +0200
committerFabian Groffen <grobian@gentoo.org>2019-06-17 20:37:26 +0200
commit624185ebb5dae086cf83da16c6430f8442be9627 (patch)
tree8d3c248663a252a035743a9d27bab22811e2cb9e /app-admin/chrpath/chrpath-0.16.ebuild
parentapp-admin/chrpath: use HTTPS, fix SRC_URI and LICENSE (diff)
downloadgentoo-624185ebb5dae086cf83da16c6430f8442be9627.tar.gz
gentoo-624185ebb5dae086cf83da16c6430f8442be9627.tar.bz2
gentoo-624185ebb5dae086cf83da16c6430f8442be9627.zip
app-admin/chrpath: EAPI=7, version bump (0.16)
Closes: https://bugs.gentoo.org/686298 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-admin/chrpath/chrpath-0.16.ebuild')
-rw-r--r--app-admin/chrpath/chrpath-0.16.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/chrpath/chrpath-0.16.ebuild b/app-admin/chrpath/chrpath-0.16.ebuild
new file mode 100644
index 000000000000..51137b39303e
--- /dev/null
+++ b/app-admin/chrpath/chrpath-0.16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Chrpath can modify the rpath and runpath of ELF executables"
+HOMEPAGE="https://directory.fsf.org/wiki/Chrpath"
+SRC_URI="https://alioth-archive.debian.org/releases/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-multilib.patch
+ "${FILESDIR}"/${P}-testsuite-1.patch
+)
+
+src_prepare() {
+ default
+ # disable installing redundant docs in the wrong dir
+ sed -i -e '/doc_DATA/d' Makefile.am || die
+ # fix for automake-1.13, #467538
+ sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${D}" -name "*.la" -delete || die
+ fi
+}