summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/chrpath/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/chrpath/files')
-rw-r--r--app-admin/chrpath/files/chrpath-0.13-multilib.patch160
-rw-r--r--app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch19
-rw-r--r--app-admin/chrpath/files/chrpath-keepgoing.patch20
3 files changed, 199 insertions, 0 deletions
diff --git a/app-admin/chrpath/files/chrpath-0.13-multilib.patch b/app-admin/chrpath/files/chrpath-0.13-multilib.patch
new file mode 100644
index 000000000000..e7db0a124053
--- /dev/null
+++ b/app-admin/chrpath/files/chrpath-0.13-multilib.patch
@@ -0,0 +1,160 @@
+Index: chrpath-0.13/Makefile.am
+===================================================================
+--- chrpath-0.13.orig/Makefile.am
++++ chrpath-0.13/Makefile.am
+@@ -12,12 +12,19 @@ debs:
+ fakeroot debian/rules binary
+
+ chrpath_SOURCES = \
+- chrpath.c \
+- killrpath.c \
+ main.c \
+- elf.c \
+ protos.h
+
++chrpath_LDADD = $(LDLIBS)
++
++lib_LTLIBRARIES = libchrpath32.la libchrpath64.la
++libchrpath32_la_SOURCES = chrpath.c killrpath.c elf.c protos.h
++libchrpath32_la_CFLAGS = -DSIZEOF_VOID_P=4
++libchrpath32_la_LDFLAGS = -avoid-version
++libchrpath64_la_SOURCES = chrpath.c killrpath.c elf.c protos.h
++libchrpath64_la_CFLAGS = -DSIZEOF_VOID_P=8
++libchrpath64_la_LDFLAGS = -avoid-version
++
+ EXTRA_DIST = ChangeLog.usermap $(man_MANS)
+
+ CLEANFILES = *.bb *.bbg *.da *.gcov testsuite/*.bb testsuite/*.bbg
+Index: chrpath-0.13/configure.ac
+===================================================================
+--- chrpath-0.13.orig/configure.ac
++++ chrpath-0.13/configure.ac
+@@ -16,6 +16,7 @@ CHRPATH_LDRPATH_OPTION
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_INSTALL
++AC_PROG_LIBTOOL
+
+ dnl Checks for libraries.
+
+@@ -26,11 +27,19 @@ AC_CHECK_HEADERS([getopt.h elf.h fcntl.h
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+ AC_C_BIGENDIAN
+-AC_CHECK_SIZEOF(void *)
+
+ dnl Checks for library functions.
+ AC_CHECK_FUNCS(getopt_long)
+
++dnl See if we need -ldl on this platform for dlopen
++LDLIBS=
++save_LIBS="$LIBS"
++LIBS=
++AC_SEARCH_LIBS([dlopen], [dl])
++LDLIBS=${LIBS}
++LIBS="${save_LIBS}"
++AC_SUBST([LDLIBS])
++
+ if eval "test x$GCC = xyes"; then
+ for flag in \
+ -ansi \
+Index: chrpath-0.13/main.c
+===================================================================
+--- chrpath-0.13.orig/main.c
++++ chrpath-0.13/main.c
+@@ -12,13 +12,19 @@
+ # include "config.h"
+ #endif
+
++#include <dlfcn.h>
++#include <elf.h>
++#include <fcntl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+ #ifdef HAVE_GETOPT_H
+ #include <getopt.h>
+ #endif
+-#include "protos.h"
++
++typedef int (*killrpath_t)(const char *filename);
++typedef int (*chrpath_t)(const char *filename, const char *newpath, int convert);
+
+ #ifdef HAVE_GETOPT_LONG
+ # define GETOPT_LONG getopt_long
+@@ -61,6 +67,30 @@ usage(char *progname)
+ printf("\n");
+ }
+
++static unsigned
++elf_class(const char *filename)
++{
++ Elf32_Ehdr ehdr;
++ int fd;
++
++ fd = open(filename, O_RDONLY);
++ if (fd == -1)
++ return 0;
++ if (read(fd, &ehdr, sizeof(ehdr)) != sizeof(ehdr))
++ {
++ close(fd);
++ return 0;
++ }
++ close(fd);
++ if ((memcmp(ehdr.e_ident, ELFMAG, SELFMAG) != 0)
++ || (ehdr.e_ident[EI_VERSION] != EV_CURRENT))
++ {
++ fprintf(stderr, "`%s' probably isn't an ELF file.\n", filename);
++ return 0;
++ }
++ return ehdr.e_ident[EI_CLASS];
++}
++
+ int
+ main(int argc, char * const argv[])
+ {
+@@ -73,6 +103,9 @@ main(int argc, char * const argv[])
+ #ifdef HAVE_GETOPT_LONG
+ int option_index = 0;
+ #endif /* HAVE_GETOPT_LONG */
++ void* dll[2];
++ killrpath_t killrpath[2];
++ chrpath_t chrpath[2];
+
+ if (argc < 2)
+ {
+@@ -116,14 +149,31 @@ main(int argc, char * const argv[])
+ }
+ } while (-1 != opt);
+
++ dll[0] = dlopen("libchrpath32.so", RTLD_LAZY);
++ killrpath[0] = (killrpath_t)dlsym(dll[0], "killrpath");
++ chrpath[0] = (chrpath_t)dlsym(dll[0], "chrpath");
++
++ dll[1] = dlopen("libchrpath64.so", RTLD_LAZY);
++ killrpath[1] = (killrpath_t)dlsym(dll[1], "killrpath");
++ chrpath[1] = (chrpath_t)dlsym(dll[1], "chrpath");
++
+ while (optind < argc && (!retval || keep_going))
+ {
++ const char* program = argv[optind++];
++ unsigned eclass = elf_class(program);
++ if (!eclass)
++ {
++ retval = 1;
++ continue;
++ }
+ if (remove)
+- retval |= killrpath(argv[optind++]);
++ retval |= killrpath[eclass - ELFCLASS32](program);
+ else
+ /* list by default, replace if path is set */
+- retval |= chrpath(argv[optind++], newpath, convert);
++ retval |= chrpath[eclass - ELFCLASS32](program, newpath, convert);
+ }
+
++ dlclose(dll[0]);
++ dlclose(dll[1]);
+ return retval;
+ }
diff --git a/app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch b/app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch
new file mode 100644
index 000000000000..1a30ce1eb94a
--- /dev/null
+++ b/app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch
@@ -0,0 +1,19 @@
+Submitted By: Mario Fetka (geos_one) (mario dot fetka at gmail dot com)
+Date: 2010-04-04
+Initial Package Version: 0.13
+Origin: me
+Upstream Status: unknown
+Description: make the testsuite run with the new mltilib design
+
+diff -Naur chrpath-0.13.orig/testsuite/runtest.sh chrpath-0.13/testsuite/runtest.sh
+--- chrpath-0.13.orig/testsuite/runtest.sh 2010-04-04 09:02:21.859114159 +0000
++++ chrpath-0.13/testsuite/runtest.sh 2010-04-04 09:42:08.762112560 +0000
+@@ -2,6 +2,8 @@
+
+ set -x
+
++export LD_LIBRARY_PATH=$PWD/../.libs:$LD_LIBRARY_PATH
++
+ CHRPATH=../chrpath
+
+ retval=0
diff --git a/app-admin/chrpath/files/chrpath-keepgoing.patch b/app-admin/chrpath/files/chrpath-keepgoing.patch
new file mode 100644
index 000000000000..d8f6965729ff
--- /dev/null
+++ b/app-admin/chrpath/files/chrpath-keepgoing.patch
@@ -0,0 +1,20 @@
+--- chrpath-0.13/main.c.orig 2006-02-27 20:21:06.000000000 +0100
++++ chrpath-0.13/main.c 2006-02-27 21:07:16.027641500 +0100
+@@ -57,6 +57,7 @@
+ printf(" -r <path>|--replace <path> Replace current rpath/runpath setting\n");
+ printf(" with the path given\n");
+ printf(" -l|--list List the current rpath/runpath (default)\n");
++ printf(" -k|--keepgoing Continue as much as possible after an error.\n");
+ printf(" -h|--help Show this usage information.\n");
+ #ifndef HAVE_GETOPT_LONG
+ printf("\n *** The long options are not available on this platform");
+--- chrpath-0.13/chrpath.1.orig 2004-09-19 10:35:44.000000000 +0200
++++ chrpath-0.13/chrpath.1 2006-02-28 10:06:28.187060500 +0100
+@@ -22,6 +22,7 @@
+ [ \fB-r\fP \fI<path>\fP |\ \fB--replace\fP \fI<path>\fP ]
+ [ \fB-c\fP | \fB--convert\fP ]
+ [ \fB-l\fP | \fB--list\fP ]
++[ \fB-k\fP | \fB--keepgoing\fP ]
+ [ \fB-h\fP | \fB--help\fP ]
+ \fI<program>\fP [ \fI<program>\fP ... ]
+ .SH DESCRIPTION