summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-09-13 13:38:38 -0400
committerMike Gilbert <floppym@gentoo.org>2016-09-13 13:38:38 -0400
commit24fc82bddb4909dc9a938ea4f3697010a3cf7d81 (patch)
tree33907ac8fa12cb33c97a55f17874f8e1d7a44ea3 /app-admin/cli53/cli53-0.8.4.ebuild
parentapp-admin/cli53: bump to 0.8.3 (diff)
downloadgentoo-24fc82bddb4909dc9a938ea4f3697010a3cf7d81.tar.gz
gentoo-24fc82bddb4909dc9a938ea4f3697010a3cf7d81.tar.bz2
gentoo-24fc82bddb4909dc9a938ea4f3697010a3cf7d81.zip
app-admin/cli53: bump to 0.8.4
Restore the live ebuild. Package-Manager: portage-2.3.0_p24
Diffstat (limited to 'app-admin/cli53/cli53-0.8.4.ebuild')
-rw-r--r--app-admin/cli53/cli53-0.8.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/cli53/cli53-0.8.4.ebuild b/app-admin/cli53/cli53-0.8.4.ebuild
new file mode 100644
index 000000000000..e6ef61418eb5
--- /dev/null
+++ b/app-admin/cli53/cli53-0.8.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+ inherit golang-vcs
+else
+ inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/barnybug/cli53/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Command line tool for Amazon Route 53"
+HOMEPAGE="https://github.com/barnybug/cli53"
+
+LICENSE="MIT"
+SLOT="0"
+
+EGO_PN="github.com/barnybug/cli53"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}" emake build
+}
+
+src_test() {
+ go test -v || die
+}
+
+src_install() {
+ dobin cli53
+ dodoc CHANGELOG.md README.md
+}