summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2016-09-22 01:55:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2016-09-22 01:58:29 +0200
commit26b428cbf35e52dde7e530fc81ae3652e3fe8d48 (patch)
treed5d780536039d8e9297626e313c12689d79b32ba /app-admin/collectd/files
parentnet-nntp/sabnzbd: bump 1.1.0 (diff)
downloadgentoo-26b428cbf35e52dde7e530fc81ae3652e3fe8d48.tar.gz
gentoo-26b428cbf35e52dde7e530fc81ae3652e3fe8d48.tar.bz2
gentoo-26b428cbf35e52dde7e530fc81ae3652e3fe8d48.zip
app-admin/collectd: Bump to v5.6.0
New plugins: - chrony - cpusleep - gps - lua - mqtt - notify_nagios - xencpu Package-Manager: portage-2.3.1
Diffstat (limited to 'app-admin/collectd/files')
-rw-r--r--app-admin/collectd/files/collectd-5.6.0-fix-apache-plugin.patch26
-rw-r--r--app-admin/collectd/files/collectd-5.6.0-gentoo.patch153
-rw-r--r--app-admin/collectd/files/collectd-5.6.0-issue-1896.patch76
3 files changed, 255 insertions, 0 deletions
diff --git a/app-admin/collectd/files/collectd-5.6.0-fix-apache-plugin.patch b/app-admin/collectd/files/collectd-5.6.0-fix-apache-plugin.patch
new file mode 100644
index 000000000000..e3afaeb5d607
--- /dev/null
+++ b/app-admin/collectd/files/collectd-5.6.0-fix-apache-plugin.patch
@@ -0,0 +1,26 @@
+From 60ec28dd104bdeef4c5ed6882fb2b663ca9da2eb Mon Sep 17 00:00:00 2001
+From: Florian Forster <octo@collectd.org>
+Date: Sun, 11 Sep 2016 20:31:31 +0200
+Subject: [PATCH] apache plugin: End statements with semi-colons.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+If only I knew why this wasn't considered a syntax error …
+---
+ src/apache.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/apache.c b/src/apache.c
+index c515e3c..5b6914c 100644
+--- a/src/apache.c
++++ b/src/apache.c
+@@ -250,7 +250,7 @@ static int config_add (oconfig_item_t *ci)
+ ssnprintf (callback_name, sizeof (callback_name),
+ "apache/%s/%s",
+ (st->host != NULL) ? st->host : hostname_g,
+- (st->name != NULL) ? st->name : "default"),
++ (st->name != NULL) ? st->name : "default");
+
+ status = plugin_register_complex_read (/* group = */ NULL,
+ /* name = */ callback_name,
diff --git a/app-admin/collectd/files/collectd-5.6.0-gentoo.patch b/app-admin/collectd/files/collectd-5.6.0-gentoo.patch
new file mode 100644
index 000000000000..dd8c1576354c
--- /dev/null
+++ b/app-admin/collectd/files/collectd-5.6.0-gentoo.patch
@@ -0,0 +1,153 @@
+From 8fe20883e248572690798e4dd1423511aa2f4e5d Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Thu, 22 Sep 2016 00:53:58 +0200
+Subject: [PATCH 1/3] Remove bundled libltdl
+
+---
+ Makefile.am | 6 ------
+ configure.ac | 8 ++++----
+ 2 files changed, 4 insertions(+), 10 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 03bdd39..ad04a3c 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,11 +1,5 @@
+-ACLOCAL_AMFLAGS = -I libltdl/m4
+-
+ SUBDIRS =
+
+-if BUILD_INCLUDED_LTDL
+-SUBDIRS += libltdl
+-endif
+-
+ SUBDIRS += proto src bindings .
+
+ AM_CPPFLAGS = $(LTDLINCL)
+diff --git a/configure.ac b/configure.ac
+index 9a6da11..68e15e0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3,7 +3,6 @@ AC_PREREQ([2.60])
+ AC_INIT([collectd],[m4_esyscmd(./version-gen.sh)])
+ AC_CONFIG_SRCDIR(src/target_set.c)
+ AC_CONFIG_HEADERS(src/config.h)
+-AC_CONFIG_AUX_DIR([libltdl/config])
+
+ dnl older automake's default of ARFLAGS=cru is noisy on newer binutils;
+ dnl we don't really need the 'u' even in older toolchains. Then there is
+@@ -13,7 +12,6 @@ m4_divert_text([DEFAULTS], [: "${ARFLAGS=cr} ${AR_FLAGS=cr}"])
+ m4_ifdef([LT_PACKAGE_VERSION],
+ # libtool >= 2.2
+ [
+- LT_CONFIG_LTDL_DIR([libltdl])
+ LT_INIT([dlopen])
+ LTDL_INIT([convenience])
+ AC_DEFINE(LIBTOOL_VERSION, 2, [Define to used libtool version.])
+@@ -25,12 +23,14 @@ m4_ifdef([LT_PACKAGE_VERSION],
+ AC_SUBST(LTDLINCL)
+ AC_SUBST(LIBLTDL)
+ AC_LIBTOOL_DLOPEN
+- AC_CONFIG_SUBDIRS(libltdl)
+ AC_DEFINE(LIBTOOL_VERSION, 1, [Define to used libtool version.])
+ ]
+ )
+
+-AM_CONDITIONAL([BUILD_INCLUDED_LTDL], [test "x$LTDLDEPS" != "x"])
++if test "x$LTDLDEPS" != "x"
++then
++ AC_MSG_ERROR(["system's libltdl is too old! Should never happen. Please file a bug at https://bugs.gentoo.org"])
++fi
+
+ AM_INIT_AUTOMAKE([subdir-objects tar-pax dist-bzip2 no-dist-gzip foreign])
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+--
+2.10.0
+
+
+From 0b00f519ce183b8ceaab5cf8e56f574ecd2cb7c4 Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Thu, 22 Sep 2016 00:54:08 +0200
+Subject: [PATCH 2/3] Remove libhal dependency
+
+X-Gentoo-Bug: 353839
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=353839
+---
+ configure.ac | 24 ------------------------
+ 1 file changed, 24 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 68e15e0..1700c44 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1663,30 +1663,6 @@ AM_CONDITIONAL(BUILD_WITH_LIBRESOLV, test "x$with_libresolv" = "xyes")
+
+ dnl Check for HAL (hardware abstraction library)
+ with_libhal="no"
+-PKG_CHECK_MODULES([HAL], [hal],
+- [
+- SAVE_LIBS="$LIBS"
+- LIBS="$HAL_LIBS $LIBS"
+- AC_CHECK_LIB([hal], [libhal_device_property_exists],
+- [
+- SAVE_CPPFLAGS="$CPPFLAGS"
+- CPPFLAGS="$HAL_CFLAGS $CPPFLAGS"
+- AC_CHECK_HEADERS([libhal.h],
+- [
+- with_libhal="yes"
+- BUILD_WITH_LIBHAL_CFLAGS="$HAL_CFLAGS"
+- BUILD_WITH_LIBHAL_LIBS="$HAL_LIBS"
+- ])
+- CPPFLAGS="$SAVE_CPPFLAGS"
+- ],
+- [ : ]
+- )
+- LIBS="$SAVE_LIBS"
+- ],
+- [ : ]
+-)
+-AC_SUBST(BUILD_WITH_LIBHAL_CFLAGS)
+-AC_SUBST(BUILD_WITH_LIBHAL_LIBS)
+
+
+ SAVE_LIBS="$LIBS"
+--
+2.10.0
+
+
+From 380c61888bed5856319fa32816d8f2f4c88ee7bc Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Thu, 22 Sep 2016 00:54:19 +0200
+Subject: [PATCH 3/3] Link Oracle plug-in against libocci
+
+Author: Aurelien Minet
+X-Gentoo-Bug: 347607
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=347607
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1700c44..83909a0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3587,14 +3587,14 @@ AC_ARG_WITH(oracle, [AS_HELP_STRING([--with-oracle@<:@=ORACLE_HOME@:>@], [Path t
+ ])
+ if test "x$ORACLE_HOME" != "x"
+ then
+- with_oracle_cppflags="-I$ORACLE_HOME/rdbms/public"
++ with_oracle_cppflags="-I$ORACLE_HOME/rdbms/public -locci"
+
+ if test -e "$ORACLE_HOME/lib/ldflags"
+ then
+ with_oracle_libs=`cat "$ORACLE_HOME/lib/ldflags"`
+ fi
+ #with_oracle_libs="-L$ORACLE_HOME/lib $with_oracle_libs -lclntsh"
+- with_oracle_libs="-L$ORACLE_HOME/lib -lclntsh"
++ with_oracle_libs="-L$ORACLE_HOME/lib -lclntsh -locci"
+ fi
+ if test "x$with_oracle" = "xyes"
+ then
+--
+2.10.0
+
diff --git a/app-admin/collectd/files/collectd-5.6.0-issue-1896.patch b/app-admin/collectd/files/collectd-5.6.0-issue-1896.patch
new file mode 100644
index 000000000000..afcd8d0a1bbb
--- /dev/null
+++ b/app-admin/collectd/files/collectd-5.6.0-issue-1896.patch
@@ -0,0 +1,76 @@
+From ba52f94929822b1968f05cfbb37985af2e0b83a4 Mon Sep 17 00:00:00 2001
+From: Florian Forster <octo@collectd.org>
+Date: Tue, 13 Sep 2016 10:44:46 +0200
+Subject: [PATCH] curl_json plugin: Skip unexpected non-map values.
+
+Assume, for example, the config `Key "*/foo"`. This config expects JSON
+in the form:
+
+ {
+ "bar": {
+ "foo": 1337
+ }
+ }
+
+If the available JSON is instead:
+
+ {
+ "error_code": 0,
+ "bar": {
+ "foo": 1337
+ }
+ }
+
+the code will take a look at the zero associated with "error_code" and
+determine that a map (with key "foo") is expected instead. Previously
+the code would continue, eventually calling `cj_get_type()` which
+expects that `key->type` is a valid pointer, resulting in a segmentation
+fault.
+
+This patch does three things to ensure that this segmentation fault does
+not happen again:
+
+1. `cj_get_type()` checks its argument to make sure it is valid before
+ dereferencing any pointers.
+2. In case a non-map is found when a map is expected, the code will
+ return instead of limping on.
+3. After calling `cj_cb_inc_array_index()`, which may update the key,
+ make sure that it actually did and that key is valid now.
+
+Fixes: #1896
+---
+ src/curl_json.c | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/src/curl_json.c b/src/curl_json.c
+index 4188f37..a547ddc 100644
+--- a/src/curl_json.c
++++ b/src/curl_json.c
+@@ -143,6 +143,9 @@ static int cj_get_type (cj_key_t *key)
+ {
+ const data_set_t *ds;
+
++ if ((key == NULL) || !CJ_IS_KEY (key))
++ return -EINVAL;
++
+ ds = plugin_get_ds (key->type);
+ if (ds == NULL)
+ {
+@@ -226,12 +229,15 @@ static int cj_cb_number (void *ctx,
+ buffer[sizeof (buffer) - 1] = 0;
+
+ if ((key == NULL) || !CJ_IS_KEY (key)) {
+- if (key != NULL && !db->state[db->depth].in_array/*can be inhomogeneous*/)
++ if (key != NULL && !db->state[db->depth].in_array/*can be inhomogeneous*/) {
+ NOTICE ("curl_json plugin: Found \"%s\", but the configuration expects"
+ " a map.", buffer);
++ return (CJ_CB_CONTINUE);
++ }
++
+ cj_cb_inc_array_index (ctx, /* update_key = */ 1);
+ key = db->state[db->depth].key;
+- if (key == NULL) {
++ if ((key == NULL) || !CJ_IS_KEY (key)) {
+ return (CJ_CB_CONTINUE);
+ }
+ }