summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas D <whissi@whissi.de>2016-02-20 00:11:26 +0100
committerThomas D <whissi@whissi.de>2016-02-23 11:04:16 +0100
commit3b459b6d37f22f9da2c070173756bf12de2591f0 (patch)
tree353a7a5a50ac1e13245bb45eb7db2a39012f37b0 /app-admin/collectd/files
parentmedia-video/movit: Fix locale handling #575438 (diff)
downloadgentoo-3b459b6d37f22f9da2c070173756bf12de2591f0.tar.gz
gentoo-3b459b6d37f22f9da2c070173756bf12de2591f0.tar.bz2
gentoo-3b459b6d37f22f9da2c070173756bf12de2591f0.zip
app-admin/collectd: Bumped to v5.5.1
- New upstream version (Closes #570766, #517060) - Bumped to EAPI=6 - Non-functional mongodb plugin disabled in ebuild (see upstream issue #492, closes #524400) - Multiple dependency problems fixed - linux-info eclass usage fixed (Closes #570778) - Support for new plugins added (amqp, genericjmx, ipvs, modbus, sigrok, tail_csv, vserver, write_riemann) - PYTHON_SINGLE_TARGET support for Python 3.4 and 3.5 enabled - Documentation improved (USE flag description, elogs) - Linux capabilities usage expanded to improve running collectd as unprivileged user (disable via filecaps USE flag) - Runscript rewritten - Runscript now supports OpenRC's default status function - Runscript now guarantees service shutdown - Validating configuration before (re)starting daemon
Diffstat (limited to 'app-admin/collectd/files')
-rw-r--r--app-admin/collectd/files/collectd-5.5.1-libocci.patch33
-rw-r--r--app-admin/collectd/files/collectd-5.5.1-lt.patch60
-rw-r--r--app-admin/collectd/files/collectd-5.5.1-nohal.patch35
-rw-r--r--app-admin/collectd/files/collectd.confd-r146
-rw-r--r--app-admin/collectd/files/collectd.initd-r179
5 files changed, 253 insertions, 0 deletions
diff --git a/app-admin/collectd/files/collectd-5.5.1-libocci.patch b/app-admin/collectd/files/collectd-5.5.1-libocci.patch
new file mode 100644
index 000000000000..e7baaa062d58
--- /dev/null
+++ b/app-admin/collectd/files/collectd-5.5.1-libocci.patch
@@ -0,0 +1,33 @@
+[PATCH 1/3] Link Oracle plug-in against libocci
+
+Author: Aurelien Minet
+X-Gentoo-Bug: 347607
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=347607
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fc1e11c..b977a0a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3248,14 +3248,14 @@ AC_ARG_WITH(oracle, [AS_HELP_STRING([--with-oracle@<:@=ORACLE_HOME@:>@], [Path t
+ ])
+ if test "x$ORACLE_HOME" != "x"
+ then
+- with_oracle_cppflags="-I$ORACLE_HOME/rdbms/public"
++ with_oracle_cppflags="-I$ORACLE_HOME/rdbms/public -locci"
+
+ if test -e "$ORACLE_HOME/lib/ldflags"
+ then
+ with_oracle_libs=`cat "$ORACLE_HOME/lib/ldflags"`
+ fi
+ #with_oracle_libs="-L$ORACLE_HOME/lib $with_oracle_libs -lclntsh"
+- with_oracle_libs="-L$ORACLE_HOME/lib -lclntsh"
++ with_oracle_libs="-L$ORACLE_HOME/lib -lclntsh -locci"
+ fi
+ if test "x$with_oracle" = "xyes"
+ then
+--
+2.7.1
+
diff --git a/app-admin/collectd/files/collectd-5.5.1-lt.patch b/app-admin/collectd/files/collectd-5.5.1-lt.patch
new file mode 100644
index 000000000000..eff1de8726ba
--- /dev/null
+++ b/app-admin/collectd/files/collectd-5.5.1-lt.patch
@@ -0,0 +1,60 @@
+[PATCH 2/3] Remove bundled libltdl
+
+---
+ Makefile.am | 6 ------
+ configure.ac | 5 -----
+ 2 files changed, 11 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index b79ea1c..d574601 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,11 +1,5 @@
+-ACLOCAL_AMFLAGS = -I libltdl/m4
+-
+ SUBDIRS =
+
+-if BUILD_INCLUDED_LTDL
+-SUBDIRS += libltdl
+-endif
+-
+ SUBDIRS += src bindings .
+
+ AM_CPPFLAGS = $(LTDLINCL)
+diff --git a/configure.ac b/configure.ac
+index b977a0a..78f3bee 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,7 +2,6 @@ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT([collectd],[m4_esyscmd(./version-gen.sh)])
+ AC_CONFIG_SRCDIR(src/)
+ AC_CONFIG_HEADERS(src/config.h)
+-AC_CONFIG_AUX_DIR([libltdl/config])
+
+ dnl older automake's default of ARFLAGS=cru is noisy on newer binutils;
+ dnl we don't really need the 'u' even in older toolchains. Then there is
+@@ -12,7 +11,6 @@ m4_divert_text([DEFAULTS], [: "${ARFLAGS=cr} ${AR_FLAGS=cr}"])
+ m4_ifdef([LT_PACKAGE_VERSION],
+ # libtool >= 2.2
+ [
+- LT_CONFIG_LTDL_DIR([libltdl])
+ LT_INIT([dlopen])
+ LTDL_INIT([convenience])
+ AC_DEFINE(LIBTOOL_VERSION, 2, [Define to used libtool version.])
+@@ -24,13 +22,10 @@ m4_ifdef([LT_PACKAGE_VERSION],
+ AC_SUBST(LTDLINCL)
+ AC_SUBST(LIBLTDL)
+ AC_LIBTOOL_DLOPEN
+- AC_CONFIG_SUBDIRS(libltdl)
+ AC_DEFINE(LIBTOOL_VERSION, 1, [Define to used libtool version.])
+ ]
+ )
+
+-AM_CONDITIONAL([BUILD_INCLUDED_LTDL], [test "x$LTDLDEPS" != "x"])
+-
+ AM_INIT_AUTOMAKE([tar-pax dist-bzip2 foreign])
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+ AC_LANG(C)
+--
+2.7.1
+
diff --git a/app-admin/collectd/files/collectd-5.5.1-nohal.patch b/app-admin/collectd/files/collectd-5.5.1-nohal.patch
new file mode 100644
index 000000000000..fcdebb5ed817
--- /dev/null
+++ b/app-admin/collectd/files/collectd-5.5.1-nohal.patch
@@ -0,0 +1,35 @@
+[PATCH 3/3] Remove libhal dependency
+
+X-Gentoo-Bug: 353839
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=353839
+---
+ configure.ac | 13 +------------
+ 1 file changed, 1 insertion(+), 12 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1c85964..cf38159 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1500,18 +1500,7 @@ AC_CHECK_LIB(resolv, res_search,
+ AM_CONDITIONAL(BUILD_WITH_LIBRESOLV, test "x$with_libresolv" = "xyes")
+
+ dnl Check for HAL (hardware abstraction library)
+-with_libhal="yes"
+-AC_CHECK_LIB(hal,libhal_device_property_exists,
+- [AC_DEFINE(HAVE_LIBHAL, 1, [Define to 1 if you have 'hal' library])],
+- [with_libhal="no"])
+-if test "x$with_libhal" = "xyes"; then
+- if test "x$PKG_CONFIG" != "x"; then
+- BUILD_WITH_LIBHAL_CFLAGS="`$PKG_CONFIG --cflags hal`"
+- BUILD_WITH_LIBHAL_LIBS="`$PKG_CONFIG --libs hal`"
+- AC_SUBST(BUILD_WITH_LIBHAL_CFLAGS)
+- AC_SUBST(BUILD_WITH_LIBHAL_LIBS)
+- fi
+-fi
++with_libhal="no"
+
+ # --with-libpthread {{{
+ AC_ARG_WITH(libpthread, [AS_HELP_STRING([--with-libpthread=@<:@=PREFIX@:>@], [Path to libpthread.])],
+--
+2.7.1
+
diff --git a/app-admin/collectd/files/collectd.confd-r1 b/app-admin/collectd/files/collectd.confd-r1
new file mode 100644
index 000000000000..2633ab0fe854
--- /dev/null
+++ b/app-admin/collectd/files/collectd.confd-r1
@@ -0,0 +1,46 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Nice value used to launch collectd, to change priority of the process. As
+# you usually we want to run it in background, a default of 5 is used.
+#
+#COLLECTD_NICELEVEL=5
+
+# Location of configuration file. Modify if you don't like the standard
+# one.
+#
+#COLLECTD_CONFIGFILE="/etc/collectd.conf"
+
+# File used to store the PID file. Usually you won't need to touch it.
+#
+#COLLECTD_PIDFILE="/run/collectd/collectd.pid"
+
+# User to run collectd as (default is collectd, change to root or give
+# collectd user appropriate privileges if you use one of the plugins that
+# require it, as e.g. ping or iptables plugins)
+#
+#COLLECTD_USER="collectd"
+
+# The group is only important if you are using collectd's UNIX socket
+# in the default location (/run/collectd) because we will chown the
+# default location to COLLECTD_USER:COLLECTD_GROUP. The default value
+# is "collectd".
+#COLLECTD_GROUP="collectd"
+
+# You can use this configuration option to pass additional options to the
+# start-stop-daemon, see start-stop-daemon(8) for more details.
+# Per default we wait 1000ms after we have started the service to ensure
+# that the daemon is really up and running.
+#COLLECTD_SSDARGS="--wait 1000"
+
+# The termination timeout (start-stop-daemon parameter "retry") ensures
+# that the service will be terminated within a given time (25 + 5 seconds
+# per default) when you are stopping the service.
+#COLLECTD_TERMTIMEOUT="TERM/25/KILL/5"
+
+# Options to collectd
+# See collectd(8) for more details
+# Notes:
+# * Do not specify another PIDFILE but use the variable above to change the location
+# * Do not specify another CONFIGFILE but use the variable above to change the location
+#COLLECTD_OPTS=""
diff --git a/app-admin/collectd/files/collectd.initd-r1 b/app-admin/collectd/files/collectd.initd-r1
new file mode 100644
index 000000000000..a90ec507eefc
--- /dev/null
+++ b/app-admin/collectd/files/collectd.initd-r1
@@ -0,0 +1,79 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+COLLECTD_CONFIGFILE=${COLLECTD_CONFIGFILE:-"/etc/collectd.conf"}
+COLLECTD_PIDFILE=${COLLECTD_PIDFILE:-"/run/collectd/collectd.pid"}
+COLLECTD_NICELEVEL=${COLLECTD_NICELEVEL:-5}
+COLLECTD_USER=${COLLECTD_USER:-"collectd"}
+COLLECTD_GROUP=${COLLECTD_GROUP:-"collectd"}
+COLLECTD_SSDARGS=${COLLECTD_SSDARGS:-"--wait 1000"}
+COLLECTD_TERMTIMEOUT=${COLLECTD_TERMTIMEOUT:-"TERM/25/KILL/5"}
+COLLECTD_OPTS=${COLLECTD_OPTS:-""}
+
+command="/usr/sbin/collectd"
+command_args="${COLLECTD_OPTS} -C \"${COLLECTD_CONFIGFILE}\" -P \"${COLLECTD_PIDFILE}\""
+start_stop_daemon_args="${COLLECTD_SSDARGS} --nice ${COLLECTD_NICELEVEL} --user ${COLLECTD_USER}:${COLLECTD_GROUP}"
+pidfile="${COLLECTD_PIDFILE}"
+retry="${COLLECTD_TERMTIMEOUT}"
+
+extra_commands="configtest"
+description_configtest="Run collectd's internal config check."
+
+required_files="\"${COLLECTD_CONFIGFILE}\""
+
+depend() {
+ use dns
+}
+
+_checkconfig() {
+ if [ $(eval sed '/^$\|^#/d' \"${COLLECTD_CONFIGFILE}\" | grep --count 'LoadPlugin[[:space:]]\+oracle') -ge 1 ] ; then
+ if [ -e /etc/env.d/50oracle-instantclient-basic ] ; then
+ . /etc/env.d/50oracle-instantclient-basic
+ export ORACLE_HOME
+ export TNS_ADMIN
+ else
+ ewarn "Unable to set Oracle environment, Oracle plugin wont work"
+ fi
+ fi
+
+ local test_command="${command} -t -C \"${COLLECTD_CONFIGFILE}\""
+
+ eval ${test_command} 1>/dev/null 2>&1
+ ret=$?
+ if [ $ret -ne 0 ]; then
+ eerror "${SVCNAME} has detected an error in your configuration:"
+ eval ${test_command}
+ fi
+
+ return $ret
+}
+
+configtest() {
+ ebegin "Checking ${SVCNAME} configuration"
+ _checkconfig
+ eend $?
+}
+
+start_pre() {
+ if [ "${RC_CMD}" != "restart" ]; then
+ configtest || return 1
+ fi
+
+ checkpath --directory --mode 0770 --owner ${COLLECTD_USER}:${COLLECTD_GROUP} "$(dirname "${COLLECTD_PIDFILE}")"
+}
+
+stop_pre() {
+ if [ "${RC_CMD}" = "restart" ]; then
+ configtest || return 1
+ fi
+}
+
+stop_post() {
+ if [ -f "${COLLECTD_PIDFILE}" ]; then
+ vebegin "Removing stale PID file"
+ rm --force "${COLLECTD_PIDFILE}"
+ veend $?
+ fi
+}