summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Pronin <dannftk@yandex.ru>2020-02-22 01:08:32 +0300
committerDaniel Pielmeier <billie@gentoo.org>2020-03-12 22:27:38 +0100
commit2a6a09f0459f11be8a9b7e24fe73972578556b61 (patch)
tree90959511681dcd52f2943c4a66c957d0415ca45d /app-admin/conky/files
parentsci-geosciences/gpsbabel: Start preparing for 1.6.0 (diff)
downloadgentoo-2a6a09f0459f11be8a9b7e24fe73972578556b61.tar.gz
gentoo-2a6a09f0459f11be8a9b7e24fe73972578556b61.tar.bz2
gentoo-2a6a09f0459f11be8a9b7e24fe73972578556b61.zip
app-admin/conky: support clang and libc++ in conky-1.10.8-r9.ebuild
provided a new patch conky-1.10.8-clang.patch Signed-off-by: Denis Pronin <dannftk@yandex.ru> Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'app-admin/conky/files')
-rw-r--r--app-admin/conky/files/conky-1.10.8-clang.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/conky/files/conky-1.10.8-clang.patch b/app-admin/conky/files/conky-1.10.8-clang.patch
new file mode 100644
index 000000000000..2fc49fa9cf25
--- /dev/null
+++ b/app-admin/conky/files/conky-1.10.8-clang.patch
@@ -0,0 +1,30 @@
+--- conky-1.10.8/src/linux.cc 2018-02-07 17:16:39.000000000 +0300
++++ conky-1.10.8.new/src/linux.cc 2020-02-22 00:43:52.336620654 +0300
+@@ -37,6 +37,7 @@
+ #include <ctype.h>
+ #include <errno.h>
+ #include <limits.h>
++#include <clocale>
+ #include <sys/types.h>
+ #include <sys/sysinfo.h>
+ #include <sys/stat.h>
+--- conky-1.10.8/src/luamm.cc 2020-02-22 00:57:25.847867585 +0300
++++ conky-1.10.8.new/src/luamm.cc 2020-02-22 00:59:29.820510124 +0300
+@@ -23,6 +23,8 @@
+
+ #include "luamm.hh"
+
++#include <cxxabi.h>
++
+ namespace lua {
+ namespace {
+
+@@ -57,7 +59,7 @@
+ lua_pushstring(l, e.what());
+ }
+ catch(...) {
+- lua_pushstring(l, ptr->__cxa_exception_type()->name());
++ lua_pushstring(l, abi::__cxa_current_exception_type()->name());
+ }
+ return 1;
+ }