summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-09-01 14:09:21 -0700
committerZac Medico <zmedico@gentoo.org>2017-09-01 14:15:11 -0700
commit1669cd44bdc753d25f560e6963f2151893ceda0f (patch)
treee620b7b2ab5afca6aa432c2d26be7c338f8a0e38 /app-admin/consul-template
parentnet-fs/samba: Removed old. (diff)
downloadgentoo-1669cd44bdc753d25f560e6963f2151893ceda0f.tar.gz
gentoo-1669cd44bdc753d25f560e6963f2151893ceda0f.tar.bz2
gentoo-1669cd44bdc753d25f560e6963f2151893ceda0f.zip
app-admin/consul-template: revbump to 0.18.5-r1 for bug 628542
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'app-admin/consul-template')
-rw-r--r--app-admin/consul-template/consul-template-0.18.5-r1.ebuild (renamed from app-admin/consul-template/consul-template-0.18.5.ebuild)0
-rw-r--r--app-admin/consul-template/files/consul-template.initd29
2 files changed, 9 insertions, 20 deletions
diff --git a/app-admin/consul-template/consul-template-0.18.5.ebuild b/app-admin/consul-template/consul-template-0.18.5-r1.ebuild
index b04c5a353362..b04c5a353362 100644
--- a/app-admin/consul-template/consul-template-0.18.5.ebuild
+++ b/app-admin/consul-template/consul-template-0.18.5-r1.ebuild
diff --git a/app-admin/consul-template/files/consul-template.initd b/app-admin/consul-template/files/consul-template.initd
index 8274f7dab3f6..f968d8d08612 100644
--- a/app-admin/consul-template/files/consul-template.initd
+++ b/app-admin/consul-template/files/consul-template.initd
@@ -1,31 +1,20 @@
#!/sbin/openrc-run
-# Copyright 2015-2016 Gentoo Foundation
+# Copyright 2015-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
description="consul-template agent"
-group=${group:-${SVCNAME}}
-pidfile=${pidfile:-"/run/${SVCNAME}/${SVCNAME}.pid"}
-user=${user:-${SVCNAME}}
+user=${user:-${RC_SVCNAME}}
+group=${group:-${RC_SVCNAME}}
+pidfile=${pidfile:-"/run/${RC_SVCNAME}.pid"}
-command="/usr/bin/${SVCNAME}"
-command_args="agent -config-dir=/etc/consul-template.d ${command_args}"
+command="/usr/bin/${RC_SVCNAME}"
+command_args="-config=/etc/consul-template.d ${command_args}"
command_background="true"
start_stop_daemon_args="--user ${user} --group ${group} \
- --stdout /var/log/${SVCNAME}/${SVCNAME}.log \
- --stderr /var/log/${SVCNAME}/${SVCNAME}.log"
+ --stdout /var/log/${RC_SVCNAME}/${RC_SVCNAME}.log \
+ --stderr /var/log/${RC_SVCNAME}/${RC_SVCNAME}.log"
+stopsig="SIGINT"
depend() {
need net
- after net
-}
-
-start_pre() {
- checkpath -d -m 0755 -o "${user}":"${group}" "${pidfile%/*}"
-}
-
-stop() {
- # SIGINT is required for graceful shutdown of consul-template
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --signal SIGINT --pidfile "${pidfile}"
- eend $?
}