summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-06-25 08:45:42 -0700
committerZac Medico <zmedico@gentoo.org>2022-06-25 08:49:27 -0700
commitd4a911d9f3d69be1e7de7300b8f22cc76152908a (patch)
tree6e330ede308ec5429bb4263945ec30bc7995e8a6 /app-admin/consul-template
parentdev-libs/nspr: Stabilize 4.34 ppc, #854258 (diff)
downloadgentoo-d4a911d9f3d69be1e7de7300b8f22cc76152908a.tar.gz
gentoo-d4a911d9f3d69be1e7de7300b8f22cc76152908a.tar.bz2
gentoo-d4a911d9f3d69be1e7de7300b8f22cc76152908a.zip
app-admin/consul-template: add 0.29.1
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-admin/consul-template')
-rw-r--r--app-admin/consul-template/Manifest2
-rw-r--r--app-admin/consul-template/consul-template-0.29.1.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/consul-template/Manifest b/app-admin/consul-template/Manifest
index 0a3f96354e2b..9dc24c045c01 100644
--- a/app-admin/consul-template/Manifest
+++ b/app-admin/consul-template/Manifest
@@ -1,2 +1,4 @@
DIST consul-template-0.29.0-deps.tar.xz 37430348 BLAKE2B 9e0af3e245420bb3166a56bf2e570300ae0d35d9d93a6f6ae08bced79b26bae102339faa955a989f0617453cd5e40c6a3358a0b265ed49f4bc2dd7cb07e605c9 SHA512 fc3ed6150bb53c27c4a8e8e8b4d2d96cf4fada966016c8fbff48d4f61d392d08fc8bd53e9fa52256c84b1e5249a34e2fe361fd96a860841337a308bc3caa7f3a
DIST consul-template-0.29.0.tar.gz 244446 BLAKE2B 9ff2b33d9a3ca296913bf4f5e6928b789341438a566b63e841e04b0ad528d13588bcdb34994a1d3a829c7d64593b9811480fcf9395d3527a09d473d90bdf4e23 SHA512 e562d89c753ca2bbd14ae57e084e7e2b0aac28c92c210357e22d32d5c3c138054a46f5fb8883a44f64bdd8e9654f457230cef3b24513fa7eeaefd177fd8004c7
+DIST consul-template-0.29.1-deps.tar.xz 59041120 BLAKE2B dd822c41cf9fdfe773ed48edbc02eb409b4840c9bd6f6b66c590d2fa6a44ccea3bcac89569abf318abd2c97e7515e600ee2f1f6c469c60d068959f90e3487831 SHA512 37fd93e9ce064251941626c6ac6b6770e7c019d82cd5f6c113d2adb09460a02fb1644af26714b34f9634e6312346edb98cd841aee6b6805f7d06a07fc7c997d7
+DIST consul-template-0.29.1.tar.gz 254592 BLAKE2B 4ad5e7c1bf2edc06d72ec1ed48f9546c698d22f8562c4c9924106891c44511b912abecc94517ed2359592b709f1f8fd05fcb00cea52893de29c62b34b61fd71e SHA512 edcfe45a3d98b9affda8b5d07fb375a647a78473c7041a87f1f5a2aa2faef2bfdef26a7037d228f6a86d0c446397e7452e7005ce16beff2bc68edabf2268a6f9
diff --git a/app-admin/consul-template/consul-template-0.29.1.ebuild b/app-admin/consul-template/consul-template-0.29.1.ebuild
new file mode 100644
index 000000000000..612bb41f3539
--- /dev/null
+++ b/app-admin/consul-template/consul-template-0.29.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module systemd
+
+DESCRIPTION="Generic template rendering and notifications with Consul"
+HOMEPAGE="https://github.com/hashicorp/consul-template"
+SRC_URI="https://github.com/hashicorp/consul-template/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 ISC MIT WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+ acct-group/consul-template
+ acct-user/consul-template"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+# TODO: debug test failures
+RESTRICT+=" test"
+
+src_prepare() {
+ default
+ # remove -s and -w from the linker flags
+ sed \
+ -e '/-s \\/d' \
+ -e '/-w \\/d' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake GOBIN="${S}"/bin dev
+}
+
+src_test() {
+ emake GOBIN="${S}"/bin test
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc CHANGELOG.md README.md
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ keepdir /etc/${PN}.d
+
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}