summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-12-13 17:09:14 -0800
committerZac Medico <zmedico@gentoo.org>2022-12-13 17:09:30 -0800
commit874fee4b7feeb88dfd8fc29c37cf2f8d7ab08b01 (patch)
tree27f200a21e15f52251e8373a62b856c352b1dd64 /app-admin/consul/consul-1.14.1.ebuild
parentapp-admin/consul: keyword 1.14.2 for ~x86 (diff)
downloadgentoo-874fee4b7feeb88dfd8fc29c37cf2f8d7ab08b01.tar.gz
gentoo-874fee4b7feeb88dfd8fc29c37cf2f8d7ab08b01.tar.bz2
gentoo-874fee4b7feeb88dfd8fc29c37cf2f8d7ab08b01.zip
app-admin/consul: drop 1.12.5, 1.12.6, 1.13.3, 1.14.0, 1.14.1
Bug: https://bugs.gentoo.org/881437 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-admin/consul/consul-1.14.1.ebuild')
-rw-r--r--app-admin/consul/consul-1.14.1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-admin/consul/consul-1.14.1.ebuild b/app-admin/consul/consul-1.14.1.ebuild
deleted file mode 100644
index 1bcbba0d09f4..000000000000
--- a/app-admin/consul/consul-1.14.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd
-
-DESCRIPTION="A tool for service discovery, monitoring and configuration"
-HOMEPAGE="https://www.consul.io"
-GIT_COMMIT="cac392a17d3f71048a949599a0f977bf9645df62"
-
-SRC_URI="https://github.com/zmedico/consul/archive/v${PV}-vendor.tar.gz -> ${P}-vendor.tar.gz"
-
-LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
-RESTRICT+=" test"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-BDEPEND="dev-go/gox"
-COMMON_DEPEND="
- acct-group/consul
- acct-user/consul"
- DEPEND="${COMMON_DEPEND}"
- RDEPEND="${COMMON_DEPEND}"
-
-S=${WORKDIR}/${P}-vendor
-
-src_prepare() {
- default
- sed -e 's|^GIT_DATE=.*|GIT_DATE=2022-11-21T16:56:07Z|' -i GNUmakefile || die
-}
-
-src_compile() {
- # The dev target sets causes build.sh to set appropriate XC_OS
- # and XC_ARCH, and skips generation of an unused zip file,
- # avoiding a dependency on app-arch/zip.
- GIT_DESCRIBE="v${PV}" \
- GIT_DIRTY="" \
- GIT_COMMIT="${GIT_COMMIT}" \
- emake dev-build
-}
-
-src_install() {
- dobin bin/consul
-
- keepdir /etc/consul.d
- insinto /etc/consul.d
- doins "${FILESDIR}/"*.json.example
-
- keepdir /var/log/consul
- fowners consul:consul /var/log/consul
-
- newinitd "${FILESDIR}/consul.initd" "${PN}"
- newconfd "${FILESDIR}/consul.confd" "${PN}"
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/consul.service"
-}