summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-05-31 17:41:12 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-05-31 17:42:25 -0500
commit0aa797efeae11d475794323415d158f6f6857142 (patch)
tree268eab66f261c994d9d3f7b5bed864db3ca2ffe4 /app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild
parentdev-vcs/hg-evolve: Version bumps and clean old (diff)
downloadgentoo-0aa797efeae11d475794323415d158f6f6857142.tar.gz
gentoo-0aa797efeae11d475794323415d158f6f6857142.tar.bz2
gentoo-0aa797efeae11d475794323415d158f6f6857142.zip
app-admin/cronlocker: synchronize a cron job across hosts
This utility uses the consul lock feature to synchronize a cron job across multiple hosts. Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild')
-rw-r--r--app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild b/app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild
new file mode 100644
index 000000000000..46e33d17179c
--- /dev/null
+++ b/app-admin/cronlocker/cronlocker-0.4.0_p20180710.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/Barzahlen/cronlocker
+HASH=c0ac605
+inherit golang-vcs-snapshot
+
+DESCRIPTION="synchronize a cron job across multiple hosts using the consul lock feature"
+HOMEPAGE="https://github.com/Barzahlen/cronlocker"
+SRC_URI="https://github.com/Barzahlen/${PN}/archive/${HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" emake cronlocker
+}
+
+src_install() {
+ pushd src/${EGO_PN}
+dobin cronlocker
+dodoc *.md package/changelog
+}