summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-25 00:59:40 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-25 01:04:22 +0100
commitc313707c6203900583762636c237bb1d3ce910b5 (patch)
treeb74eb8371db5ec0657c30089262c6b6f83bfc31b /app-admin/cronolog/cronolog-1.6.2-r5.ebuild
parentapp-admin/pprocm: EAPI 6 bump. (diff)
downloadgentoo-c313707c6203900583762636c237bb1d3ce910b5.tar.gz
gentoo-c313707c6203900583762636c237bb1d3ce910b5.tar.bz2
gentoo-c313707c6203900583762636c237bb1d3ce910b5.zip
app-admin/cronolog: EAPI 6 bump.
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-admin/cronolog/cronolog-1.6.2-r5.ebuild')
-rw-r--r--app-admin/cronolog/cronolog-1.6.2-r5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/cronolog/cronolog-1.6.2-r5.ebuild b/app-admin/cronolog/cronolog-1.6.2-r5.ebuild
new file mode 100644
index 000000000000..121f6cf721a3
--- /dev/null
+++ b/app-admin/cronolog/cronolog-1.6.2-r5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="Log rotation software"
+HOMEPAGE="https://github.com/fordmason/cronolog"
+SRC_URI="http://cronolog.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-patches"/*.txt
+ "${FILESDIR}/${P}-umask.patch"
+)
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}