summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormudler <mudler@sabayon.org>2016-06-03 16:32:49 +0200
committermudler <mudler@sabayon.org>2016-06-03 16:55:40 +0200
commit805b73850954391097542fc2f69d7e27855822ef (patch)
tree836c2a9b5388f0939a91b8e7c0efe038c5f62b02 /app-admin/equo/equo-302.ebuild
parentxfce-extra/xfce4-whiskermenu-plugin: add myself as maintainer (diff)
downloadgentoo-805b73850954391097542fc2f69d7e27855822ef.tar.gz
gentoo-805b73850954391097542fc2f69d7e27855822ef.tar.bz2
gentoo-805b73850954391097542fc2f69d7e27855822ef.zip
app-admin/equo: version bump to 302
drop version 254, old and bugged Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=527306 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-admin/equo/equo-302.ebuild')
-rw-r--r--app-admin/equo/equo-302.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/equo/equo-302.ebuild b/app-admin/equo/equo-302.ebuild
new file mode 100644
index 000000000000..90026e7d48d5
--- /dev/null
+++ b/app-admin/equo/equo-302.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ ~sys-apps/entropy-${PV}[${PYTHON_USEDEP}]"
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/file[python]"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_compile() {
+ cd "${S}"/client || die
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}"/client || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+
+ python_optimize "${D}/usr/lib/entropy/client"
+}