summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2019-11-12 14:49:52 +0100
committerAgostino Sarubbo <ago@gentoo.org>2019-11-12 14:49:52 +0100
commit77230ef71377c0b45f0510ed089fb10d7097093f (patch)
tree108d6cdc650c41be180325b7ecd11e7a10b5d1b1 /app-admin/exo/exo-1.6.0.ebuild
parentdev-python/hcloud-python: amd64 stable (diff)
downloadgentoo-77230ef71377c0b45f0510ed089fb10d7097093f.tar.gz
gentoo-77230ef71377c0b45f0510ed089fb10d7097093f.tar.bz2
gentoo-77230ef71377c0b45f0510ed089fb10d7097093f.zip
app-admin/exo: version bump to 1.6.0
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/exo/exo-1.6.0.ebuild')
-rw-r--r--app-admin/exo/exo-1.6.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/exo/exo-1.6.0.ebuild b/app-admin/exo/exo-1.6.0.ebuild
new file mode 100644
index 000000000000..ebb329b957ff
--- /dev/null
+++ b/app-admin/exo/exo-1.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://exoscale.github.io/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_install() {
+ dobin ${PN}
+}