summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2016-10-18 11:49:07 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-24 13:25:43 +0200
commit1ed462767bda5e7dcae6e78006cf150feca2d636 (patch)
tree8333ecf52ca00401a125f40fca08fd6914c34c3d /app-admin/filebeat/filebeat-1.3.1.ebuild
parentprofiles/features/prefix/make.defaults: disable user* features. (diff)
downloadgentoo-1ed462767bda5e7dcae6e78006cf150feca2d636.tar.gz
gentoo-1ed462767bda5e7dcae6e78006cf150feca2d636.tar.bz2
gentoo-1ed462767bda5e7dcae6e78006cf150feca2d636.zip
app-admin/filebeat: new package.
Filebeat is part of the Beats family by Elasticsearch. It's a lightweight log forwarder to Logstash & Elasticsearch. We already have a binary version of the package in tree, but this non-binary should eventually remove it. Package-Manager: portage-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/2585 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin/filebeat/filebeat-1.3.1.ebuild')
-rw-r--r--app-admin/filebeat/filebeat-1.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/filebeat/filebeat-1.3.1.ebuild b/app-admin/filebeat/filebeat-1.3.1.ebuild
new file mode 100644
index 000000000000..12dee30f9907
--- /dev/null
+++ b/app-admin/filebeat/filebeat-1.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-lang/go"
+RDEPEND="!app-admin/filebeat-bin"
+
+ELASTIC="${WORKDIR}/src/github.com/elastic"
+BEATS="${ELASTIC}/beats"
+S="${BEATS}"
+
+src_unpack() {
+ mkdir -p "${ELASTIC}" || die
+ unpack ${P}.tar.gz
+ mv beats-${PV} "${BEATS}" || die
+}
+
+src_compile() {
+ cd ${BEATS}/filebeat || die
+ GOPATH="${WORKDIR}" emake
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /var/lib/${PN}
+
+ fperms 0750 /var/lib/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ insinto /etc/${PN}
+ newins ${PN}/etc/${PN}.yml ${PN}.yml.example
+
+ dobin filebeat/filebeat
+}