summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2019-03-04 11:59:14 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-03-04 16:54:42 +0100
commit60e5e6ec64eb84b9c76e21db38141565d3eb3eab (patch)
tree2cb57d392c345982afa880bbbb288cf506de20ed /app-admin/filebeat/filebeat-6.6.1.ebuild
parentapp-admin/logstash-bin: drop vulnerable (diff)
downloadgentoo-60e5e6ec64eb84b9c76e21db38141565d3eb3eab.tar.gz
gentoo-60e5e6ec64eb84b9c76e21db38141565d3eb3eab.tar.bz2
gentoo-60e5e6ec64eb84b9c76e21db38141565d3eb3eab.zip
app-admin/filebeat: bump to 6.6.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-admin/filebeat/filebeat-6.6.1.ebuild')
-rw-r--r--app-admin/filebeat/filebeat-6.6.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/filebeat/filebeat-6.6.1.ebuild b/app-admin/filebeat/filebeat-6.6.1.ebuild
new file mode 100644
index 000000000000..560d23c545ca
--- /dev/null
+++ b/app-admin/filebeat/filebeat-6.6.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.11.2"
+RDEPEND="!app-admin/filebeat-bin"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # avoid Elastic license
+ rm -r x-pack || die
+
+ # use ${PV} instead of git commit id
+ sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT}/usr/share/doc/${PF}/examples"
+}