summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-05 10:15:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-05 11:14:28 +0200
commit14d44c5e99a80115f6cb466d336305e0a2c8488c (patch)
tree90aeea3001ea8d6aeb919170c7150911bae7f72a /app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild
parentRename app-admin/{undertaker → gentoo-retirement}-scripts (diff)
downloadgentoo-14d44c5e99a80115f6cb466d336305e0a2c8488c.tar.gz
gentoo-14d44c5e99a80115f6cb466d336305e0a2c8488c.tar.bz2
gentoo-14d44c5e99a80115f6cb466d336305e0a2c8488c.zip
app-admin/gentoo-retirement-scripts: Bump to v2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild')
-rw-r--r--app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild b/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild
new file mode 100644
index 000000000000..4267e6014067
--- /dev/null
+++ b/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit python-single-r1
+
+DESCRIPTION="Scripts to help retiring Gentoo developers"
+HOMEPAGE="https://github.com/mgorny/gentoo-retirement-scripts/"
+SRC_URI="
+ https://github.com/mgorny/gentoo-retirement-scripts/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-bugzilla[${PYTHON_USEDEP}]
+ ')"
+
+src_compile() {
+ python_fix_shebang .
+}
+
+src_install() {
+ exeinto /opt/gentoo-retirement-scripts
+ doexe *.py
+ insinto /opt/gentoo-retirement-scripts
+ doins *.template
+}