summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-09-30 12:27:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-09-30 12:29:04 -0500
commit922588f677796766925cc26f9e2a5cf7c6231769 (patch)
treef72778b0456f7824fa90da6a49afaa8bd64ed515 /app-admin/glance/glance-2020.1.9999.ebuild
parentdev-python/osprofiler: add DISTUTILS_USE_SETUPTOOLS=bdepend (diff)
downloadgentoo-922588f677796766925cc26f9e2a5cf7c6231769.tar.gz
gentoo-922588f677796766925cc26f9e2a5cf7c6231769.tar.bz2
gentoo-922588f677796766925cc26f9e2a5cf7c6231769.zip
app-admin/glance: add DISTUTILS_USE_SETUPTOOLS=bdepend
Closes: https://bugs.gentoo.org/745732 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/glance/glance-2020.1.9999.ebuild')
-rw-r--r--app-admin/glance/glance-2020.1.9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/app-admin/glance/glance-2020.1.9999.ebuild b/app-admin/glance/glance-2020.1.9999.ebuild
index 3136ae3593d4..779d30ba55d3 100644
--- a/app-admin/glance/glance-2020.1.9999.ebuild
+++ b/app-admin/glance/glance-2020.1.9999.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_7 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
DESCRIPTION="Services for discovering, registering, and retrieving VM images"
@@ -25,9 +26,7 @@ REQUIRED_USE="|| ( mysql postgres sqlite )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
+DEPEND="${CDEPEND}"
#note to self, wsgiref is a python builtin, no need to package it
#>=dev-python/wsgiref-0.1.2[${PYTHON_USEDEP}]