summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-05-14 15:08:53 +0000
committerThomas Deutschmann <whissi@gentoo.org>2021-05-28 21:23:52 +0200
commitdf7fd36f30ab7d8767b427f00364ef3bf1f1c5ee (patch)
treed7084d04403263adf403553b58ca2bac8ee3e8c0 /app-admin/graylog
parentapp-admin/graylog: bump to 3.3.13 (diff)
downloadgentoo-df7fd36f30ab7d8767b427f00364ef3bf1f1c5ee.tar.gz
gentoo-df7fd36f30ab7d8767b427f00364ef3bf1f1c5ee.tar.bz2
gentoo-df7fd36f30ab7d8767b427f00364ef3bf1f1c5ee.zip
app-admin/graylog: bump to 4.0.7
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-admin/graylog')
-rw-r--r--app-admin/graylog/Manifest1
-rw-r--r--app-admin/graylog/graylog-4.0.7.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-admin/graylog/Manifest b/app-admin/graylog/Manifest
index e306e3972a0f..421f6dff6a98 100644
--- a/app-admin/graylog/Manifest
+++ b/app-admin/graylog/Manifest
@@ -3,3 +3,4 @@ DIST graylog-3.3.11.tgz 129320028 BLAKE2B c90641ba1f5abaaeeba452dc623e6b6dd65ff5
DIST graylog-3.3.13.tgz 129316329 BLAKE2B ea90edfbffaeba5a022a012ddd87b83d9d5cbd9a2d348c78dd44c22cd95fe5f2f5d5eccc067066b2fd52e0ea944827c02f89233396ee70ef4a440c52e2a8da0c SHA512 7360408db9abbba472f44a01898edb55d9a07306b03dc9ee1b1ac84df2835dd5afccc5c29fbc07137da3cce2f1c59dd26974ad6f6a2ee6e69e1679916227e115
DIST graylog-4.0.2.tgz 163286730 BLAKE2B 102b410b89e776c43ce97442407e0e7a418b0e9c9ac82747e4e049b83e8c88a865861e365ecc57fcd45dd4dc7bd763ba9f8657038526523c3f341be73daf647a SHA512 535451f84bc28e9716d34138637b732a4ebe879970051f720997d93828846a2ac707a58a14f14e10fa0aa4e3aeed5694ac0339275ef2623d5ac01712067158ca
DIST graylog-4.0.5.tgz 163294449 BLAKE2B 3b3c7e74bdfbc37bb4a416733b70d153b399b66cf97215a476aa3304dead0143a60253514c804e6cbeb5b4e2935e79a9e8ff16b88d2067c8820dcc5aaf7331aa SHA512 d9df101560fa0dcf63043c1dd41342caea58d77d24e81da0912270b6b627c1ec1c30900902a8456bcd3dd1281d4d57b499defc4e0da0a58bbc61ad53f1843448
+DIST graylog-4.0.7.tgz 190560623 BLAKE2B 329a61bb6e8f08fc670a7f9673c5e67fb197febf8ab85737c651e1f8c3a078e3528d9058f0d707bd1e3ed94fa3dc60c2a70a7f931a8cea79d31c96099a86117c SHA512 991e2eec505cfde6a7254d4fa332c564e81142afec7a3b879a60ca10b7366cba46823c078f043cc5e700e462d2ba7d23fa6774ab3e58903bed91b8b5494c9d5e
diff --git a/app-admin/graylog/graylog-4.0.7.ebuild b/app-admin/graylog/graylog-4.0.7.ebuild
new file mode 100644
index 000000000000..e0b3f8d98a4d
--- /dev/null
+++ b/app-admin/graylog/graylog-4.0.7.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Free and open source log management"
+HOMEPAGE="https://www.graylog.org"
+SRC_URI="https://downloads.graylog.org/releases/graylog/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="!app-admin/graylog2
+ acct-group/graylog
+ acct-user/graylog
+ >=virtual/jdk-1.8:*"
+
+DOCS=(
+ README.markdown UPGRADING.rst
+)
+
+GRAYLOG_DATA_DIR="/var/lib/graylog"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog"
+QA_PREBUILT="${GRAYLOG_INSTALL_DIR}/lib/sigar/libsigar*"
+
+src_prepare() {
+ default
+
+ # Stick to architecture of build host
+ if ! use amd64; then
+ rm -r lib/sigar/libsigar-amd64-*.so || die "Failed in removing AMD64 support libraries"
+ fi
+ if ! use ppc64; then
+ rm -r lib/sigar/libsigar-ppc64-*.so || die "Failed in removing PPC64 support libraries"
+ fi
+ if ! use x86; then
+ rm -r lib/sigar/libsigar-x86-*.so || die "Failed in removing X86 support libraries"
+ fi
+ # Currently unsupported platforms
+ # QA warning galore but testing/patches welcome
+ rm lib/sigar/libsigar-*freebsd*so \
+ lib/sigar/libsigar-*solaris*so \
+ lib/sigar/libsigar-*hpux*.sl \
+ lib/sigar/libsigar-*macosx*.dylib \
+ lib/sigar/libsigar-ia64-*.so \
+ lib/sigar/libsigar-ppc-*.so \
+ lib/sigar/libsigar-s390x*.so \
+ lib/sigar/*winnt* || die "Failed in removing unsupported platform libraries"
+
+ # gentoo specific paths
+ sed -i "s@\(node_id_file = \).*@\1${GRAYLOG_DATA_DIR}/node-id@g; \
+ s@\(message_journal_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/journal@g;" \
+ graylog.conf.example || die
+}
+
+src_install() {
+ default
+
+ insinto /etc/graylog
+ doins graylog.conf.example
+
+ insinto "${GRAYLOG_INSTALL_DIR}"
+ doins graylog.jar
+ doins -r lib plugin
+
+ keepdir "${GRAYLOG_DATA_DIR}"
+
+ newconfd "${FILESDIR}/graylog.confd" graylog
+ newinitd "${FILESDIR}/graylog.initd" graylog
+}
+
+pkg_postinst() {
+ ewarn "Graylog does not depend on need.net any more (#439092)."
+ ewarn
+ ewarn "Please configure rc_need according to your binding address in:"
+ ewarn "/etc/conf.d/graylog"
+}