summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGokturk Yuksek <gokturk@binghamton.edu>2016-01-28 16:42:45 -0500
committerGokturk Yuksek <gokturk@binghamton.edu>2016-01-28 17:00:32 -0500
commitec8fe7845ac2a5a71764726461247c0254c23740 (patch)
tree8ade879816055f83af6793587bed8d7c5ab193ec /app-admin/lastpass-cli/lastpass-cli-0.8.1.ebuild
parentapp-admin/lastpass-cli: bump 0.7.1 to 0.7.2 for the upcoming cert change (diff)
downloadgentoo-ec8fe7845ac2a5a71764726461247c0254c23740.tar.gz
gentoo-ec8fe7845ac2a5a71764726461247c0254c23740.tar.bz2
gentoo-ec8fe7845ac2a5a71764726461247c0254c23740.zip
app-admin/lastpass-cli: bump 0.8.0 to 0.8.1 for the upcoming cert change
X-Upstream-Issue-URL: https://github.com/lastpass/lastpass-cli/issues/88 Package-Manager: portage-2.2.24
Diffstat (limited to 'app-admin/lastpass-cli/lastpass-cli-0.8.1.ebuild')
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-0.8.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/lastpass-cli/lastpass-cli-0.8.1.ebuild b/app-admin/lastpass-cli/lastpass-cli-0.8.1.ebuild
new file mode 100644
index 000000000000..8bb6a25f0af2
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-0.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl X +pinentry"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND} app-text/asciidoc"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}/usr"
+ emake PREFIX="${EPREFIX}/usr" doc-man
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install-doc
+}