summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2017-05-22 17:05:12 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2017-05-22 17:05:51 -0400
commit2d1b3ecdaa377617df46bd46785c86547d5ed75e (patch)
tree8aa0e103d8b35a240ff6aa27ee51827856934087 /app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild
parentsys-apps/guix: bump up to 0.13.0 (diff)
downloadgentoo-2d1b3ecdaa377617df46bd46785c86547d5ed75e.tar.gz
gentoo-2d1b3ecdaa377617df46bd46785c86547d5ed75e.tar.bz2
gentoo-2d1b3ecdaa377617df46bd46785c86547d5ed75e.zip
app-admin/lastpass-cli: bump to 1.1.2 #617534
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild')
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild b/app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild
new file mode 100644
index 000000000000..d81e760b556d
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-1.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils bash-completion-r1
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl X +pinentry"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBASH_COMPLETION_COMPLETIONSDIR="$(get_bashcompdir)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile all doc-man
+}
+
+src_install() {
+ cmake-utils_src_install install install-doc
+}