summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/lastpass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/lastpass')
-rw-r--r--app-admin/lastpass/Manifest3
-rw-r--r--app-admin/lastpass/lastpass-3.1.61.ebuild111
-rw-r--r--app-admin/lastpass/metadata.xml15
3 files changed, 129 insertions, 0 deletions
diff --git a/app-admin/lastpass/Manifest b/app-admin/lastpass/Manifest
new file mode 100644
index 000000000000..b2067e930839
--- /dev/null
+++ b/app-admin/lastpass/Manifest
@@ -0,0 +1,3 @@
+DIST lp_linux.xpi 3965257 SHA256 1d98b3649f51e5f08a16379a73791b7e85fa5fab35b3a6190860c900788c5dbc SHA512 e39a6ada0e75dcb3bf943bce9b573bf8d22be7c07baf86f3651cbaaa5abcec7c31dd43341369b1fe562aff572befd1f15114ba030e6b9fb317bd476798d7b5e5 WHIRLPOOL 85f7eebc2f155d4beb7a1f69ef9d1e58508c76ac2807536d7a07885f395f342b218587199c9b57a77f9e54e75e1dfaf311341c16a59830c114283e542aa18767
+DIST lpchrome_linux.crx 4722909 SHA256 511fd7968bb45ab1425ca9584873f4dbf0812b63c64a4e604796cb0a76849f3f SHA512 01935a34a0be63b96556009cb50364df83599aeab6cad10d7e4b49af5a5acfeecf61171aa36f932901a42e2e0b58141e649d17525a259343fe9b2f287d413dc0 WHIRLPOOL 230f2c820d2cf8d3a937866c5c3dde8b7f05e37547180a4e666bc0bac592671f5c1d7bb84498d5bd930053e47ec80d75207dcaba1b71f307d1ea011d80e9e5f9
+DIST lplinux.tar.bz2 1523508 SHA256 535fe4ce97a55f3baf9311962a7a4812ea7a32c8a545ee1e533c0794c665abf1 SHA512 4433701df5a6c04bb914f3b342c458a28ff7cd232936f77dfec6ddd959060be1e8bf067b88e05d1c1ac69f63f1660c49c262f85515d6cf97188ea365f7bf309b WHIRLPOOL 818f00fc43944b8eb1c0f4816e82fa06be69845d1d6a3eb8de453db1647e9bfdce0ff0812ea9c0fec64c904dce1cc1fa4c514a79ead2c5e98aeb7416a8a2fb41
diff --git a/app-admin/lastpass/lastpass-3.1.61.ebuild b/app-admin/lastpass/lastpass-3.1.61.ebuild
new file mode 100644
index 000000000000..cae55ad6ab16
--- /dev/null
+++ b/app-admin/lastpass/lastpass-3.1.61.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Online password manager and form filler that makes web browsing easier and more secure"
+HOMEPAGE="https://lastpass.com/misc_download2.php"
+# sadly, upstream has no versioned distfiles
+MAINDISTFILE=lplinux.tar.bz2
+SRC_URI="
+ https://lastpass.com/${MAINDISTFILE}
+ https://lastpass.com/lpchrome_linux.crx
+ firefox? ( https://lastpass.com/lp_linux.xpi )"
+
+LICENSE="LastPass"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE="+chromium +firefox +chrome"
+RESTRICT="strip mirror" # We can't mirror it, but we can fetch it
+
+DEPEND=""
+RDEPEND="
+ chrome? ( || (
+ www-client/google-chrome
+ www-client/google-chrome-beta
+ www-client/google-chrome-unstable
+ ) )
+ chromium? ( >=www-client/chromium-32.0.1700.102 )
+ firefox? ( www-client/firefox )"
+REQUIRED_USE="|| ( firefox chromium chrome )"
+
+LASTPASS_EXEDIR=/opt/lastpass/
+
+QA_PREBUILT="
+ ${LASTPASS_EXEDIR}nplastpass*
+ /usr/lib*/nsbrowser/plugins/libnplastpass*.so
+ /usr/lib*/firefox/browser/extensions/support@lastpass.com/platform/Linux_x86_64-gcc3/components/lpxpcom_x86_64.so
+ /usr/lib*/firefox/browser/extensions/support@lastpass.com/platform/Linux_x86-gcc3/components/lpxpcom.so
+"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${MAINDISTFILE}
+ mkdir -p "${S}"/crx || die
+ # bug #524864: strip Chrome CRX header
+ # otherwise the unzip warning can be fatal in some cases
+ dd bs=306 skip=1 if="${DISTDIR}"/lpchrome_linux.crx of="${T}"/lpchrome_linux.zip 2>/dev/null || die
+ unzip -qq -o "${T}"/lpchrome_linux.zip -d "${S}"/crx || die
+}
+
+src_install() {
+ # This is based on the upstream installer script that's in the tarball
+ bin=nplastpass
+ use amd64 && bin="${bin}64"
+ exeinto ${LASTPASS_EXEDIR}
+ doexe "${S}"/$bin
+
+ # despite the name, this piece seems used by both firefox+chrome
+ exeinto /usr/$(get_libdir)/nsbrowser/plugins
+ doexe "${S}"/crx/lib${bin}.so
+
+ cat >"${T}"/lastpass_policy.json <<-EOF
+ {
+ "ExtensionInstallSources": [
+ "https://lastpass.com/*",
+ "https://*.lastpass.com/*",
+ "https://*.cloudfront.net/lastpass/*"
+ ]
+ }
+ EOF
+ cat >"${T}"/com.lastpass.nplastpass.json <<-EOF
+ {
+ "name": "com.lastpass.nplastpass",
+ "description": "LastPass",
+ "path": "${LASTPASS_EXEDIR}/$bin",
+ "type": "stdio",
+ "allowed_origins": [
+ "chrome-extension://hdokiejnpimakedhajhdlcegeplioahd/",
+ "chrome-extension://debgaelkhoipmbjnhpoblmbacnmmgbeg/",
+ "chrome-extension://hnjalnkldgigidggphhmacmimbdlafdo/"
+ ]
+ }
+ EOF
+
+ if use chromium; then
+ insinto /etc/chromium/policies/managed
+ doins "${T}"/lastpass_policy.json
+ insinto /etc/opt/chrome/native-messaging-hosts/
+ doins "${T}"/com.lastpass.nplastpass.json
+ fi
+ if use chrome; then
+ insinto /etc/opt/chrome/policies/managed/
+ doins "${T}"/lastpass_policy.json
+ insinto /etc/chromium/native-messaging-hosts
+ doins "${T}"/com.lastpass.nplastpass.json
+ fi
+
+ if use firefox; then
+ d="$D/usr/$(get_libdir)/firefox/browser/extensions/support@lastpass.com"
+ mkdir -p $d || die
+ unzip -qq -o "${DISTDIR}/lp_linux.xpi" -d "$d" || die
+ fi
+
+}
+
+pkg_postinst() {
+ einfo "Visit https://lastpass.com/dl/inline/?full=1 to finish installing for Chrome/Chromium/Firefox"
+}
diff --git a/app-admin/lastpass/metadata.xml b/app-admin/lastpass/metadata.xml
new file mode 100644
index 000000000000..556c09be3436
--- /dev/null
+++ b/app-admin/lastpass/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <use>
+ <flag name="firefox">Support for <pkg>www-client/firefox</pkg></flag>
+ <flag name="chromium">Support for <pkg>www-client/chromium</pkg></flag>
+ <flag name="chrome">Support for <pkg>www-client/chrome</pkg></flag>
+ </use>
+</pkgmetadata>