summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2016-12-02 23:57:09 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2016-12-02 23:57:38 +0100
commit3c29e6efb3b7d074d21985f0c4e7b4ce3a08461f (patch)
treef3481157eff475f9c300c1971259c7640520f4f5 /app-admin/logrotate/files
parentnet-misc/lldpd: Remove old (diff)
downloadgentoo-3c29e6efb3b7d074d21985f0c4e7b4ce3a08461f.tar.gz
gentoo-3c29e6efb3b7d074d21985f0c4e7b4ce3a08461f.tar.bz2
gentoo-3c29e6efb3b7d074d21985f0c4e7b4ce3a08461f.zip
app-admin/logrotate: Bumps version to 3.11.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin/logrotate/files')
-rw-r--r--app-admin/logrotate/files/logrotate-3.11.0-Werror.patch12
-rw-r--r--app-admin/logrotate/files/logrotate-3.11.0-fbsd.patch57
-rw-r--r--app-admin/logrotate/files/logrotate-3.11.0-ignore-hidden.patch14
-rw-r--r--app-admin/logrotate/files/logrotate-3.11.0-lfs.patch11
-rw-r--r--app-admin/logrotate/files/logrotate-3.11.0-noasprintf.patch55
5 files changed, 149 insertions, 0 deletions
diff --git a/app-admin/logrotate/files/logrotate-3.11.0-Werror.patch b/app-admin/logrotate/files/logrotate-3.11.0-Werror.patch
new file mode 100644
index 000000000000..43c0ebaeb189
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate-3.11.0-Werror.patch
@@ -0,0 +1,12 @@
+diff -Nuar a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2016-11-30 13:05:55.000000000 +0100
++++ b/Makefile.am 2016-12-02 23:46:15.288908073 +0100
+@@ -8,7 +8,7 @@
+ # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ # GNU General Public License for more details.
+ #
+-AM_CFLAGS = -Wall -Werror
++AM_CFLAGS = -Wall
+ sbin_PROGRAMS = logrotate
+ logrotate_SOURCES = basenames.c config.c log.c logrotate.c \
+ basenames.h config.h log.h logrotate.h queue.h
diff --git a/app-admin/logrotate/files/logrotate-3.11.0-fbsd.patch b/app-admin/logrotate/files/logrotate-3.11.0-fbsd.patch
new file mode 100644
index 000000000000..f5aa65272b88
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate-3.11.0-fbsd.patch
@@ -0,0 +1,57 @@
+diff -Nuar a/config.c b/config.c
+--- a/config.c 2016-12-02 23:33:36.768905615 +0100
++++ b/config.c 2016-12-02 23:36:15.568906130 +0100
+@@ -1,6 +1,6 @@
+ #include "queue.h"
+ /* Alloca is defined in stdlib.h in NetBSD */
+-#ifndef __NetBSD__
++#if !defined(__NetBSD__) && !defined(__FreeBSD__)
+ #include <alloca.h>
+ #endif
+ #include <limits.h>
+@@ -24,6 +24,10 @@
+ #include <fnmatch.h>
+ #include <sys/mman.h>
+
++#if !defined(PATH_MAX) && defined(__FreeBSD__)
++#include <sys/param.h>
++#endif
++
+ #include "basenames.h"
+ #include "log.h"
+ #include "logrotate.h"
+diff -Nuar a/logrotate.c b/logrotate.c
+--- a/logrotate.c 2016-11-30 14:07:15.000000000 +0100
++++ b/logrotate.c 2016-12-02 23:36:44.218906223 +0100
+@@ -1,6 +1,6 @@
+ #include "queue.h"
+ /* alloca() is defined in stdlib.h in NetBSD */
+-#ifndef __NetBSD__
++#if !defined(__NetBSD__) && !defined(__FreeBSD__)
+ #include <alloca.h>
+ #endif
+ #include <limits.h>
+@@ -26,6 +26,10 @@
+ #include <limits.h>
+ #endif
+
++#if !defined(PATH_MAX) && defined(__FreeBSD__)
++#include <sys/param.h>
++#endif
++
+ #include "basenames.h"
+ #include "log.h"
+ #include "logrotate.h"
+diff -Nuar a/Makefile.legacy b/Makefile.legacy
+--- a/Makefile.legacy 2016-11-30 13:05:55.000000000 +0100
++++ b/Makefile.legacy 2016-12-02 23:37:33.938906384 +0100
+@@ -22,7 +22,9 @@
+
+ ifeq ($(WITH_ACL),yes)
+ CFLAGS += -DWITH_ACL
++ifneq ($(OS_NAME),FreeBSD)
+ LOADLIBES += -lacl
++endif
+ # See pretest
+ TEST_ACL=1
+ else
diff --git a/app-admin/logrotate/files/logrotate-3.11.0-ignore-hidden.patch b/app-admin/logrotate/files/logrotate-3.11.0-ignore-hidden.patch
new file mode 100644
index 000000000000..104f202efd27
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate-3.11.0-ignore-hidden.patch
@@ -0,0 +1,14 @@
+diff -Nuar a/config.c b/config.c
+--- a/config.c 2016-11-30 13:05:55.000000000 +0100
++++ b/config.c 2016-12-02 23:33:36.768905615 +0100
+@@ -383,7 +383,9 @@
+ int i;
+
+ /* Check if fname is '.' or '..'; if so, return false */
+- if (fname[0] == '.' && (!fname[1] || (fname[1] == '.' && !fname[2])))
++ /* Don't include 'hidden' files either; this breaks Gentoo
++ portage config file management http://bugs.gentoo.org/87683 */
++ if (fname[0] == '.')
+ return 0;
+
+ /* Check if fname is ending in a taboo-extension; if so, return false */
diff --git a/app-admin/logrotate/files/logrotate-3.11.0-lfs.patch b/app-admin/logrotate/files/logrotate-3.11.0-lfs.patch
new file mode 100644
index 000000000000..9cd5745e846a
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate-3.11.0-lfs.patch
@@ -0,0 +1,11 @@
+diff -Nuar a/configure.ac b/configure.ac
+--- a/configure.ac 2016-12-02 14:08:40.000000000 +0100
++++ b/configure.ac 2016-12-02 23:48:03.878908425 +0100
+@@ -12,6 +12,7 @@
+ AC_PROG_CC_STDC
+ AC_STRUCT_ST_BLKSIZE
+ AC_STRUCT_ST_BLOCKS
++AC_SYS_LARGEFILE
+
+ dnl Use 64-bit file offsets on 32-bit systems (defines C macros if necessary)
+ AC_SYS_LARGEFILE
diff --git a/app-admin/logrotate/files/logrotate-3.11.0-noasprintf.patch b/app-admin/logrotate/files/logrotate-3.11.0-noasprintf.patch
new file mode 100644
index 000000000000..36733a25d03b
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate-3.11.0-noasprintf.patch
@@ -0,0 +1,55 @@
+diff -Nuar a/config.c b/config.c
+--- a/config.c 2016-12-02 23:36:15.568906130 +0100
++++ b/config.c 2016-12-02 23:41:17.438907108 +0100
+@@ -49,39 +49,6 @@
+ #include "asprintf.c"
+ #endif
+
+-#if !defined(HAVE_ASPRINTF) && !defined(_FORTIFY_SOURCE)
+-#include <stdarg.h>
+-
+-int asprintf(char **string_ptr, const char *format, ...)
+-{
+- va_list arg;
+- char *str;
+- int size;
+- int rv;
+-
+- va_start(arg, format);
+- size = vsnprintf(NULL, 0, format, arg);
+- size++;
+- va_start(arg, format);
+- str = malloc(size);
+- if (str == NULL) {
+- va_end(arg);
+- /*
+- * Strictly speaking, GNU asprintf doesn't do this,
+- * but the caller isn't checking the return value.
+- */
+- fprintf(stderr, "failed to allocate memory\\n");
+- exit(1);
+- }
+- rv = vsnprintf(str, size, format, arg);
+- va_end(arg);
+-
+- *string_ptr = str;
+- return (rv);
+-}
+-
+-#endif
+-
+ #if !defined(HAVE_STRNDUP)
+ char *strndup(const char *s, size_t n)
+ {
+diff -Nuar a/logrotate.h b/logrotate.h
+--- a/logrotate.h 2016-11-30 13:05:55.000000000 +0100
++++ b/logrotate.h 2016-12-02 23:40:54.518907034 +0100
+@@ -82,8 +82,5 @@
+ extern int debug;
+
+ int readAllConfigPaths(const char **paths);
+-#if !defined(asprintf) && !defined(_FORTIFY_SOURCE)
+-int asprintf(char **string_ptr, const char *format, ...);
+-#endif
+
+ #endif