summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/logstash-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/logstash-bin')
-rw-r--r--app-admin/logstash-bin/Manifest2
-rw-r--r--app-admin/logstash-bin/files/agent.conf.sample21
-rw-r--r--app-admin/logstash-bin/files/logstash.confd2
-rw-r--r--app-admin/logstash-bin/files/logstash.initd33
-rw-r--r--app-admin/logstash-bin/files/logstash.logrotate6
-rw-r--r--app-admin/logstash-bin/logstash-bin-1.4.4.ebuild50
-rw-r--r--app-admin/logstash-bin/logstash-bin-1.5.3.ebuild53
-rw-r--r--app-admin/logstash-bin/metadata.xml14
8 files changed, 181 insertions, 0 deletions
diff --git a/app-admin/logstash-bin/Manifest b/app-admin/logstash-bin/Manifest
new file mode 100644
index 000000000000..04b039cc543e
--- /dev/null
+++ b/app-admin/logstash-bin/Manifest
@@ -0,0 +1,2 @@
+DIST logstash-1.4.4.tar.gz 71931272 SHA256 b148a76670a11f879e26622e229c882f3c98950e695f2d7ec066522c3c658658 SHA512 e8252167fb6c75462dc910f86d2a5ce4f718d108705f16ea7fc80e0e6446d8649e1d0310a8024bf785bb51834a55ab79cf435541a88b7c7eb8cd640683df8635 WHIRLPOOL c5d3c5e50dc1d306be739c72df746163e43c7772087c52253050a92c69ec02c7c924279eca77782f3089b92db359278732f2adbfb02549748d2559fedf612329
+DIST logstash-1.5.3.tar.gz 91690052 SHA256 a54abaade1c31e65187f77fca1738bc9e6c8e95b4ee3176a2bc44735b6dd0cf8 SHA512 7cd9a522a8f99448954e973b38f17477f8f4d645ab3971492e94a25097ad52aa65446ec8caebcf1c3f7b756b76e1b70d139f27c6140a09d2c97d41dd3fb9b78e WHIRLPOOL ce1f020e2af0082a3e65caf5d09b52089c04f584a1fe024a933c1077d115d7fcd5fd119aedfbdf3d2d01fe42ed120f331f517472e9eb5797095970b8aeb68a11
diff --git a/app-admin/logstash-bin/files/agent.conf.sample b/app-admin/logstash-bin/files/agent.conf.sample
new file mode 100644
index 000000000000..9d125cd6a25e
--- /dev/null
+++ b/app-admin/logstash-bin/files/agent.conf.sample
@@ -0,0 +1,21 @@
+input {
+ stdin {
+ type => "stdin"
+ }
+
+ file {
+ type => "syslog"
+ path => [ "/var/log/*.log", "/var/log/debug", "/var/log/messages", "/var/log/syslog" ]
+ }
+}
+
+output {
+ stdout {
+ codec => rubydebug
+ }
+
+ elasticsearch {
+ host => localhost
+ cluster => elasticsearch
+ }
+}
diff --git a/app-admin/logstash-bin/files/logstash.confd b/app-admin/logstash-bin/files/logstash.confd
new file mode 100644
index 000000000000..29f4d1c016ae
--- /dev/null
+++ b/app-admin/logstash-bin/files/logstash.confd
@@ -0,0 +1,2 @@
+#LOGSTASH_USER=""
+#LOGSTASH_GROUP=""
diff --git a/app-admin/logstash-bin/files/logstash.initd b/app-admin/logstash-bin/files/logstash.initd
new file mode 100644
index 000000000000..08b063fe7044
--- /dev/null
+++ b/app-admin/logstash-bin/files/logstash.initd
@@ -0,0 +1,33 @@
+#!/sbin/openrc-run
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+LOGSTASH_USER=${LOGSTASH_USER:-root}
+LOGSTASH_GROUP=${LOGSTASH_GROUP:-root}
+LOGFILE="/var/log/logstash/logstash.log"
+
+command="/opt/logstash/bin/logstash"
+command_args="agent --config /etc/logstash/conf.d/*.conf --log ${LOGFILE}"
+extra_commands="checkconfig"
+command_background="true"
+start_stop_daemon_args="--user=\"${LOGSTASH_USER}\""
+pidfile="/run/logstash/logstash.pid"
+
+depend() {
+ use net
+ after elasticsearch
+}
+
+checkconfig() {
+ ebegin "Checking your configuration"
+ ${command} ${command_args} --configtest
+ eend $? "Configuration error. Please fix your configuration files."
+}
+
+start_pre() {
+ checkconfig || return 1
+
+ checkpath -d -o "${LOGSTASH_USER}":"${LOGSTASH_GROUP}" -m750 "$(dirname "${pidfile}")"
+ checkpath -d -o "${LOGSTASH_USER}":"${LOGSTASH_GROUP}" -m750 "$(dirname "${LOGFILE}")"
+ checkpath -f -o "${LOGSTASH_USER}":"${LOGSTASH_GROUP}" -m640 "${LOGFILE}"
+}
diff --git a/app-admin/logstash-bin/files/logstash.logrotate b/app-admin/logstash-bin/files/logstash.logrotate
new file mode 100644
index 000000000000..013c8ea921b9
--- /dev/null
+++ b/app-admin/logstash-bin/files/logstash.logrotate
@@ -0,0 +1,6 @@
+/var/log/logstash/*.log {
+ copytruncate
+ compress
+ missingok
+ notifempty
+}
diff --git a/app-admin/logstash-bin/logstash-bin-1.4.4.ebuild b/app-admin/logstash-bin/logstash-bin-1.4.4.ebuild
new file mode 100644
index 000000000000..027faae0d39d
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-1.4.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN/-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( virtual/jre:1.8 virtual/jre:1.7 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/etc/${MY_PN}/conf.d"
+ doins "${FILESDIR}/agent.conf.sample"
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}"
+
+ insinto /etc/logrotate.d
+ doins "${FILESDIR}/${MY_PN}.logrotate"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd" "${MY_PN}"
+}
+
+pkg_postinst() {
+ einfo "Getting started with logstash:"
+ einfo " https://www.elastic.co/guide/en/logstash/current/getting-started-with-logstash.html"
+ einfo ""
+ einfo "Packages that might be interesting:"
+ einfo " app-misc/elasticsearch"
+ einfo " dev-python/elasticsearch-curator"
+ einfo " www-apps/kibana-bin"
+}
diff --git a/app-admin/logstash-bin/logstash-bin-1.5.3.ebuild b/app-admin/logstash-bin/logstash-bin-1.5.3.ebuild
new file mode 100644
index 000000000000..18df7a31ce3f
--- /dev/null
+++ b/app-admin/logstash-bin/logstash-bin-1.5.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN/-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+DEPEND=""
+RDEPEND="|| ( virtual/jre:1.8 virtual/jre:1.7 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+ keepdir "/var/log/${MY_PN}"
+
+ insinto "/etc/${MY_PN}/conf.d"
+ doins "${FILESDIR}/agent.conf.sample"
+
+ insinto "/opt/${MY_PN}"
+ doins -r .
+ fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby"
+
+ insinto /etc/logrotate.d
+ doins "${FILESDIR}/${MY_PN}.logrotate"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.initd" "${MY_PN}"
+}
+
+pkg_postinst() {
+ einfo "Getting started with logstash:"
+ einfo " https://www.elastic.co/guide/en/logstash/current/getting-started-with-logstash.html"
+ einfo ""
+ einfo "Packages that might be interesting:"
+ einfo " app-misc/elasticsearch"
+ einfo " dev-python/elasticsearch-curator"
+ einfo " www-apps/kibana-bin"
+}
diff --git a/app-admin/logstash-bin/metadata.xml b/app-admin/logstash-bin/metadata.xml
new file mode 100644
index 000000000000..df4f52042dae
--- /dev/null
+++ b/app-admin/logstash-bin/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <maintainer>
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomas Mozes</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
+</pkgmetadata>