summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-10-04 10:48:02 +0200
committerUltrabug <ultrabug@gentoo.org>2016-10-04 10:50:05 +0200
commitc1e833e4485ccc761d2176496bd4e8a5c24f9d73 (patch)
treefed30c6c9b78eca8fdbdc3dabb6ff37ab6c9d91c /app-admin/mongo-tools/mongo-tools-3.2.10.ebuild
parentnet-misc/connman-gtk: add self as maintainer (diff)
downloadgentoo-c1e833e4485ccc761d2176496bd4e8a5c24f9d73.tar.gz
gentoo-c1e833e4485ccc761d2176496bd4e8a5c24f9d73.tar.bz2
gentoo-c1e833e4485ccc761d2176496bd4e8a5c24f9d73.zip
app-admin/mongo-tools: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-admin/mongo-tools/mongo-tools-3.2.10.ebuild')
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.2.10.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/mongo-tools-3.2.10.ebuild b/app-admin/mongo-tools/mongo-tools-3.2.10.ebuild
new file mode 100644
index 000000000000..81808be14276
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.2.10.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="http://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl"
+
+# Maintainer note:
+# openssl DEPEND constraint, see:
+# https://github.com/mongodb/mongo-tools/issues/11
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e 's|go build .*|go build -o "bin/$i" -tags "$tags" "$i/main/$i.go"|g' -i build.sh || die
+}
+
+src_compile() {
+ local myconf
+
+ if use sasl; then
+ myconf="${myconf} sasl"
+ fi
+
+ if use ssl; then
+ myconf="${myconf} ssl"
+ fi
+
+ ./build.sh ${myconf}
+}
+
+src_install() {
+ dobin bin/*
+}