summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-04-29 11:36:45 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2022-05-10 20:19:36 +0000
commit670a279bd308a8db562d8639f81ed198cd5e1330 (patch)
tree9bd0016ab6f072624b880b931a3f1295854e83b1 /app-admin/mongosh-bin
parentsys-cluster/keepalived: bump to 2.2.7 (diff)
downloadgentoo-670a279bd308a8db562d8639f81ed198cd5e1330.tar.gz
gentoo-670a279bd308a8db562d8639f81ed198cd5e1330.tar.bz2
gentoo-670a279bd308a8db562d8639f81ed198cd5e1330.zip
app-admin/mongosh-bin: bump to 1.3.1
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25257 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'app-admin/mongosh-bin')
-rw-r--r--app-admin/mongosh-bin/Manifest2
-rw-r--r--app-admin/mongosh-bin/mongosh-bin-1.3.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/mongosh-bin/Manifest b/app-admin/mongosh-bin/Manifest
index a7850e0f747c..15b50d854cbb 100644
--- a/app-admin/mongosh-bin/Manifest
+++ b/app-admin/mongosh-bin/Manifest
@@ -1,2 +1,4 @@
DIST mongosh-1.1.9_arm64.tgz 60765908 BLAKE2B 9658285f084b22ea60eaaf0c6aca78362e483b65a0153da1da37ea4d2d233509a145e2aa7f88425169815dda4443eeae9a890fc2a91020294118089260419e20 SHA512 35d7bc3409e5bec874203d8868b863ad13f6b66e82ac933848b245aaae4ab85a7c0db3879e262e62435af44f7aa0f6c46ec27e6b21f5e0d227cda5dfd623f7e2
DIST mongosh-1.1.9_x64.tgz 62020005 BLAKE2B 2b634fe864bef24bd93f6676acf57d877d745e1407ec150a75e26c498affa39dbfb5918d6645ac33a3c0990a2c33dc464ad2748e7bd9b536111a86dc856a21cb SHA512 99f2b66a7adbd8a395d46e610fa493eff974ace54b2e5cf395b572e023270e5ce3fdf7e7b73bedd3f7f31c2f46964647920920c32ac7460def71dfc5630c26b8
+DIST mongosh-1.3.1_arm64.tgz 61196774 BLAKE2B 6d48f06d2378d0d1f46f896b445e4022a5a8c0f7d6b9225dadf909734a721255eb0d4b6daccf52886db07a1f3186125abef10603e4cf91791b4d93c0d6ca2a30 SHA512 46519e1ccda8490ac1336014c17250392402c7497b34fdb4cdefdab322913f740b2699e2f1a94aeee5441157025586900f1ffe3bac40e4eca5e1858cdc2e406b
+DIST mongosh-1.3.1_x64.tgz 62428646 BLAKE2B f92434ff73890ba38498bc51d9a497d7feab240e7bbe380565b1bf54fa58018d24250c70f20f634248b481b5b41d0c4bdea0bf130347a1fdd547cfc7d655de67 SHA512 2650f05f40594736985e11cede4d59dcce0c620654ab7c136084a94b816bafd3d2cc6ab8be05e1c844cad9221f436e9aa2e9e670cbae6505fe6d28c12cf608dd
diff --git a/app-admin/mongosh-bin/mongosh-bin-1.3.1.ebuild b/app-admin/mongosh-bin/mongosh-bin-1.3.1.ebuild
new file mode 100644
index 000000000000..2466be1376d5
--- /dev/null
+++ b/app-admin/mongosh-bin/mongosh-bin-1.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="The MongoDB Shell"
+HOMEPAGE="https://github.com/mongodb-js/mongosh https://www.mongodb.com/products/shell"
+
+SRC_URI_BASE="https://downloads.mongodb.com/compass/${MY_P}-linux"
+SRC_URI="amd64? ( ${SRC_URI_BASE}-x64.tgz -> ${MY_P}_x64.tgz )
+ arm64? ( ${SRC_URI_BASE}-arm64.tgz -> ${MY_P}_arm64.tgz )"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-4.0 ISC MIT WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="dev-libs/cyrus-sasl[kerberos]"
+
+# Do not complain about CFLAGS etc since we don't use them
+QA_FLAGS_IGNORED='.*'
+
+src_unpack() {
+ if use amd64; then
+ S="${WORKDIR}/${MY_P}-linux-x64"
+ elif use arm64; then
+ S="${WORKDIR}/${MY_P}-linux-arm64"
+ fi
+
+ default
+}
+
+src_install() {
+ dobin bin/mongosh
+}