summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/packagekit-qt4
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/packagekit-qt4')
-rw-r--r--app-admin/packagekit-qt4/Manifest2
-rw-r--r--app-admin/packagekit-qt4/metadata.xml11
-rw-r--r--app-admin/packagekit-qt4/packagekit-qt4-0.7.4.ebuild68
-rw-r--r--app-admin/packagekit-qt4/packagekit-qt4-0.8.8.ebuild29
4 files changed, 110 insertions, 0 deletions
diff --git a/app-admin/packagekit-qt4/Manifest b/app-admin/packagekit-qt4/Manifest
new file mode 100644
index 000000000000..9165b8578bd1
--- /dev/null
+++ b/app-admin/packagekit-qt4/Manifest
@@ -0,0 +1,2 @@
+DIST PackageKit-0.7.4.tar.xz 1493656 SHA256 4112c86d67afbbb9be5d3a706c63c537babbbe1f96e398ae306f5e5e02563a98 SHA512 a2cee60f499ec6c5359f3dc2eddda02cfb9c287f80a6b38aa1d9d87558ce5938ade87ab34f6cb1f9640749a0f19625b44c89f72dea5fbb0cbd5f34aec8dbb9f6 WHIRLPOOL 2827cb038c86164ae58021fafe9f2bbf21e69b5c63c4ef5e0f613806f5725f910af3d5aa51646fd258da9c91b81b086cf9560f66bf042e1cb6d1c25128f984b3
+DIST PackageKit-Qt-0.8.8.tar.xz 41416 SHA256 e234d4b1f8451821930f463621a86c9708eebfd1db65019883d38a60d13c870c SHA512 a81b85588f531ca58d355094a78c3f07aa804350fdd49f98fbae02076ebb1d4736c0a3d33822805a9e1b5ee5bf62e85141994b841c5e9218b7d03715b45dde11 WHIRLPOOL 319b2226fcf1a7de58df016b2cd401779601ad1842f0d35c9341f56d380397d9dc92a7cd8c8291fb0c4487f7821f4c860130b6275523a240bc3e8996d425f973
diff --git a/app-admin/packagekit-qt4/metadata.xml b/app-admin/packagekit-qt4/metadata.xml
new file mode 100644
index 000000000000..187f7a710efe
--- /dev/null
+++ b/app-admin/packagekit-qt4/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ </maintainer>
+ <use>
+ </use>
+</pkgmetadata>
+
diff --git a/app-admin/packagekit-qt4/packagekit-qt4-0.7.4.ebuild b/app-admin/packagekit-qt4/packagekit-qt4-0.7.4.ebuild
new file mode 100644
index 000000000000..19b3e366eccf
--- /dev/null
+++ b/app-admin/packagekit-qt4/packagekit-qt4-0.7.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils base
+
+MY_PN="PackageKit"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Qt4 PackageKit backend library"
+HOMEPAGE="http://www.packagekit.org/"
+SRC_URI="http://www.packagekit.org/releases/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=">=dev-qt/qtcore-4.4.0:4
+ >=dev-qt/qtdbus-4.4.0:4
+ >=dev-qt/qtsql-4.4.0:4
+ ~app-admin/packagekit-base-${PV}"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # http://pkgs.fedoraproject.org/gitweb/?p=PackageKit.git;a=commit;h=0b378668288db34890b82c7be007fc76c7fcd956
+ sed -i -e '/polkit-backend-1/d' configure || die #423431
+ econf \
+ --enable-introspection=no \
+ --localstatedir=/var \
+ --disable-dependency-tracking \
+ --enable-option-checking \
+ --enable-libtool-lock \
+ --disable-strict \
+ --disable-local \
+ --disable-gtk-doc \
+ --disable-command-not-found \
+ --disable-debuginfo-install \
+ --disable-gstreamer-plugin \
+ --disable-service-packs \
+ --disable-man-pages \
+ --disable-cron \
+ --disable-gtk-module \
+ --disable-networkmanager \
+ --disable-browser-plugin \
+ --disable-pm-utils \
+ --disable-device-rebind \
+ --disable-tests \
+ --enable-qt
+}
+
+src_compile() {
+ local qtdir=packagekit-qt2
+ cd "${S}"/lib/${qtdir} || die
+ emake || die "emake install failed"
+}
+
+src_install() {
+ local qtdir=packagekit-qt2
+ cd "${S}"/lib/${qtdir} || die
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/app-admin/packagekit-qt4/packagekit-qt4-0.8.8.ebuild b/app-admin/packagekit-qt4/packagekit-qt4-0.8.8.ebuild
new file mode 100644
index 000000000000..2bbda4609688
--- /dev/null
+++ b/app-admin/packagekit-qt4/packagekit-qt4-0.8.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils cmake-utils
+
+MY_PN="PackageKit-Qt"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Qt4 PackageKit backend library"
+HOMEPAGE="http://www.packagekit.org/"
+SRC_URI="http://www.packagekit.org/releases/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=">=dev-qt/qtcore-4.4.0:4
+ >=dev-qt/qtdbus-4.4.0:4
+ >=dev-qt/qtsql-4.4.0:4
+ >=app-admin/packagekit-base-0.8.15-r1"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"