summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-11-16 08:08:44 +0100
committerFlorian Schmaus <flow@gentoo.org>2021-11-16 09:16:29 +0100
commitb692f5c9fb28b184f599e6fc8123023a0149ef0a (patch)
treedfa636986df6db9ebedabe04fd0deccd98acfe16 /app-admin/passwordsafe
parentpackage.mask: unmask >=dev-games/mygui-3.4.0 (diff)
downloadgentoo-b692f5c9fb28b184f599e6fc8123023a0149ef0a.tar.gz
gentoo-b692f5c9fb28b184f599e6fc8123023a0149ef0a.tar.bz2
gentoo-b692f5c9fb28b184f599e6fc8123023a0149ef0a.zip
app-admin/passwordsafe: fix icon, EAPI=8
fix icon installation path and handling, move to EAPI 8 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-admin/passwordsafe')
-rw-r--r--app-admin/passwordsafe/passwordsafe-1.14.0-r1.ebuild (renamed from app-admin/passwordsafe/passwordsafe-1.14.0.ebuild)8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-admin/passwordsafe/passwordsafe-1.14.0.ebuild b/app-admin/passwordsafe/passwordsafe-1.14.0-r1.ebuild
index 42ae73ac83fd..89108fe1776f 100644
--- a/app-admin/passwordsafe/passwordsafe-1.14.0.ebuild
+++ b/app-admin/passwordsafe/passwordsafe-1.14.0-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
WX_GTK_VER="3.0-gtk3"
-inherit cmake desktop flag-o-matic optfeature wxwidgets
+inherit cmake desktop flag-o-matic optfeature wxwidgets xdg
MY_PV="${PV/_beta/BETA}"
DESCRIPTION="Password manager with wxGTK based frontend"
@@ -79,10 +79,12 @@ src_install() {
insinto /usr/share/${PN}
doins -r xml
- doicon install/graphics/pwsafe.png
+ doicon -s 48 install/graphics/pwsafe.png
newmenu install/desktop/pwsafe.desktop ${PN}.desktop
}
pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
optfeature "on-screen keyboard for password entry" x11-misc/xvkbd
}