summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-10-28 13:11:38 +0200
committerUlrich Müller <ulm@gentoo.org>2023-11-21 18:52:34 +0100
commitc62f38ad3a6beb047826cc1808bb3c48f6ac9760 (patch)
treef42658dfed94db835739b73ccad9918d5ea5d292 /app-admin/pprocm/pprocm-1.0-r4.ebuild
parentapp-admin/pprocm: update HOMEPAGE, add github remote-id (diff)
downloadgentoo-c62f38ad3a6beb047826cc1808bb3c48f6ac9760.tar.gz
gentoo-c62f38ad3a6beb047826cc1808bb3c48f6ac9760.tar.bz2
gentoo-c62f38ad3a6beb047826cc1808bb3c48f6ac9760.zip
app-admin/pprocm: revision bump which uses sources from github
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-admin/pprocm/pprocm-1.0-r4.ebuild')
-rw-r--r--app-admin/pprocm/pprocm-1.0-r4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/pprocm/pprocm-1.0-r4.ebuild b/app-admin/pprocm/pprocm-1.0-r4.ebuild
new file mode 100644
index 000000000000..09f5fb8a385b
--- /dev/null
+++ b/app-admin/pprocm/pprocm-1.0-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="PProcM"
+GIT_COMMIT="98ca63f43afb9ec8491cceb81f62850ff00379e0"
+
+DESCRIPTION="Ncurses-based program to monitor CPU, disk, network and memory usage"
+HOMEPAGE="https://github.com/ZachGoldberg/Perl-Proc-Monitor-PProcM/"
+SRC_URI="https://github.com/ZachGoldberg/Perl-Proc-Monitor-PProcM/archive/${GIT_COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/Perl-Proc-Monitor-PProcM-${GIT_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/IO-Pipely
+ dev-perl/POE
+ dev-perl/Sys-Statistics-Linux
+"
+
+src_install() {
+ newbin "${MY_PN}" "${PN}"
+ einstalldocs
+}