summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-03-24 20:36:54 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-03-24 20:40:12 -0500
commit3dfc50bc4f22e0a8a1b0994cbe7c2270cc9d7752 (patch)
tree71209284b6cb73ff6b1f86e24c7b02ba3ce127c6 /app-admin/puppet-agent
parentapp-admin/puppet: 7.15.0 bump (diff)
downloadgentoo-3dfc50bc4f22e0a8a1b0994cbe7c2270cc9d7752.tar.gz
gentoo-3dfc50bc4f22e0a8a1b0994cbe7c2270cc9d7752.tar.bz2
gentoo-3dfc50bc4f22e0a8a1b0994cbe7c2270cc9d7752.zip
app-admin/puppet-agent: 7.15.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.15.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index fae2bfefb1fb..5f84e0a6b9f8 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,2 +1,4 @@
DIST puppet-agent_7.14.0-1focal_amd64.deb 20339972 BLAKE2B 3e7a230e73c1eb7d96317e7877fc1bf5dbfb44f2e8faa65a1ba08ca3c7c22115458797e1bf33450d5f45c11ed0a96c2973a0d6a0a83d98739ad52c90fe45f3af SHA512 08cd94e1d5ed1a8827f43a60c80ab64a8370ecebab01cd9d8b6c36e99007a84d9b6d39a8a8eb6370b2e78f2360d4fc0b95bf85f8b59a38b44b4d94a4e266d4b7
DIST puppet-agent_7.14.0-1focal_arm64.deb 19534676 BLAKE2B a809b4beb8c20ce2e45f1c2c552585403494ed2c0eca719077597106fcb91478bfe7cb12bcb420e5b093840fe41f4ae101c978df48690ea47940216dda7b293e SHA512 4d57fe41d6943b3b6d643f55aead3264ed4f4aedd280e8fc0ed8504a1f7e0da1e9a06e9d7e2b4916f2de2c6726b3dcff3ce8096d02503443ad6e74b0528177bc
+DIST puppet-agent_7.15.0-1focal_amd64.deb 20342292 BLAKE2B 4d8a322182b10462353b4fb78b8a655765e6b91e31626c34126862cf27d7863ed6dcfdf6d8545c9bfb2be25e42bd0f3f34c5726885dc6508eb71aa09646e647a SHA512 b6887ef66c47fcfce7136e13ff96f7a8df8b11011fd9ec8cb01a79d8a7f7b77e43da63033d9c42446c4131ffe04e8bfaf5bdf70ba1cb6c37dcd1d6963024ef29
+DIST puppet-agent_7.15.0-1focal_arm64.deb 19533904 BLAKE2B 234fc85f20df8bba9d1f33e84ac725326201984c041ab371dd645df2e6cce12b6c81481ceff01819dc884d3c8f6191d6e98aafbb78a6856733b4cc3255d0e905 SHA512 70f389bc29270317fc621ef7be2eea9764b490ae2da32fb3968bd2c966eec53ef7e65469ea7fd5069676e23feede48557575b9020783b50292b146cc17ae840e
diff --git a/app-admin/puppet-agent/puppet-agent-7.15.0.ebuild b/app-admin/puppet-agent/puppet-agent-7.15.0.ebuild
new file mode 100644
index 000000000000..3ef55d1516d2
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-7.15.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="amd64? ( http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb )
+arm64? ( http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_arm64.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+# virtual/libcrypt:= is in here despite being a pre-built package
+# to ensure that the has_version logic for the symlink doesn't become stale
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet
+ virtual/libcrypt:="
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt[compat]
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+
+ # Handling of the path to the crypt library during the ongoing migration
+ # from glibc[crypt] to libxcrypt
+ # https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html
+ if has_version "sys-libs/glibc[crypt]"; then
+ local crypt_target='../../../../usr/lib64/xcrypt/libcrypt.so.1'
+ else
+ local crypt_target='../../../../usr/lib/libcrypt.so.1'
+ fi
+ dosym $crypt_target /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet-agent.conf
+}