summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-11-17 10:46:18 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-11-17 10:49:20 -0600
commit43651c7bebc5cd9d2be946ba5ad39591ceef18ee (patch)
tree20e998665abc173f0131b0917e7662dcfc5ba9cf /app-admin/puppet-agent
parentapp-admin/puppet: 7.11.0 cleanup (diff)
downloadgentoo-43651c7bebc5cd9d2be946ba5ad39591ceef18ee.tar.gz
gentoo-43651c7bebc5cd9d2be946ba5ad39591ceef18ee.tar.bz2
gentoo-43651c7bebc5cd9d2be946ba5ad39591ceef18ee.zip
app-admin/puppet-agent: 7.11.0 cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest1
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.11.0-r1.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 7faf77d14c1e..af820e4fb049 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,2 +1 @@
-DIST puppet-agent_7.11.0-1focal_amd64.deb 20968988 BLAKE2B 41c1464290fc38b9bb2a79384c6c427ec8cd1332b3ccba155cb26d43a87b36931415d3a54a10ae8f6a1322f02eeaef27147d4af7304f541ce38e668b072cc03c SHA512 38024f80af5ef69a1db22f9ed90b7b00af5183988b2029fa63a8b2fa1de1c189ba164d8cd450156c4d822a3e6404e5933ca09efdd4eeee7188c99791991a9921
DIST puppet-agent_7.12.0-1focal_amd64.deb 20971412 BLAKE2B afb9af877e578b6ae24566e0688d14fa67fdb133a3fd9e15dc2473ea76f61a6551bd69a6fad18b6b555eea2afa8fd858a005f2c1cf6681c28f4422129211dea9 SHA512 f5fdab728baa7813f31ba174b0ee7e9dee3f5f954ed46a2f6740cf6ad075c8f36a1b6cb28e7c6223eb4aad02400252114a5dcede0085f7a7e7ba079bad2aedf9
diff --git a/app-admin/puppet-agent/puppet-agent-7.11.0-r1.ebuild b/app-admin/puppet-agent/puppet-agent-7.11.0-r1.ebuild
deleted file mode 100644
index 77dd8d3fbcfa..000000000000
--- a/app-admin/puppet-agent/puppet-agent-7.11.0-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit systemd unpacker tmpfiles
-
-DESCRIPTION="general puppet client utils along with hiera and facter"
-HOMEPAGE="https://puppetlabs.com/"
-SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="puppetdb selinux"
-RESTRICT="strip"
-
-# virtual/libcrypt:= is in here despite being a pre-built package
-# to ensure that the has_version logic for the symlink doesn't become stale
-CDEPEND="!app-admin/puppet
- !dev-ruby/hiera
- !dev-ruby/facter
- app-emulation/virt-what
- acct-user/puppet
- acct-group/puppet
- virtual/libcrypt:="
-
-DEPEND="
- ${CDEPEND}
- app-admin/augeas"
-RDEPEND="${CDEPEND}
- app-portage/eix
- sys-apps/dmidecode
- sys-libs/libselinux
- sys-libs/glibc
- sys-libs/readline:0/8
- sys-libs/libxcrypt[compat]
- sys-libs/ncurses:0[tinfo]
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
-
-S=${WORKDIR}
-
-QA_PREBUILT="*"
-
-src_install() {
- # conf.d
- doconfd etc/default/puppet
- doconfd etc/default/pxp-agent
- # logrotate.d
- insinto /etc/logrotate.d
- doins etc/logrotate.d/pxp-agent
- # puppet itself
- insinto /etc/puppetlabs
- doins -r etc/puppetlabs/*
- # logdir for systemd
- keepdir var/log/puppetlabs/puppet/
- chmod 0750 var/log/puppetlabs/puppet/
- # the rest
- insinto /opt
- dodir opt/puppetlabs/puppet/cache
- doins -r opt/*
- fperms 0750 /opt/puppetlabs/puppet/cache
- # init
- newinitd "${FILESDIR}/puppet.initd2" puppet
- systemd_dounit lib/systemd/system/puppet.service
- systemd_dounit lib/systemd/system/pxp-agent.service
- newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
- # symlinks
- chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
- dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
- dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
- dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
-
- # Handling of the path to the crypt library during the ongoing migration
- # from glibc[crypt] to libxcrypt
- # https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html
- if has_version "sys-libs/glibc[crypt]"; then
- local crypt_target='../../../../usr/lib64/xcrypt/libcrypt.so.1'
- else
- local crypt_target='../../../../usr/lib/libcrypt.so.1'
- fi
- dosym $crypt_target /opt/puppetlabs/puppet/lib/libcrypt.so.1
-}
-
-pkg_postinst() {
- tmpfiles_process puppet-agent.conf
-}