summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-06-15 06:17:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-06-15 06:17:17 -0500
commit70d57252d2f0581740f72549d07f9b56e677e77d (patch)
tree9d96addec42e56d6ffa3817f5f5cb2d5d239973e /app-admin/puppet-agent
parentsys-cluster/nova: bup (diff)
downloadgentoo-70d57252d2f0581740f72549d07f9b56e677e77d.tar.gz
gentoo-70d57252d2f0581740f72549d07f9b56e677e77d.tar.bz2
gentoo-70d57252d2f0581740f72549d07f9b56e677e77d.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.5.2.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 9b40c2eaac40..fb89d1e9cd20 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -4,3 +4,5 @@ DIST puppet-agent_1.5.0-1xenial_amd64.deb 12958702 SHA256 288bc9cdf318d5a373889e
DIST puppet-agent_1.5.0-1xenial_i386.deb 14003222 SHA256 88c4560b1e49f000e0b36ac8a567faa8b1c49c244722cb4bb63e78a6109a21b2 SHA512 b4fd141c481411b08e4b8e65eb28dbd749e5a84bf20070b2fb818fcf34e18828d6c7edc222784f0ae363b07bb634ee12f7114a31b720ef601962dc354b6cd94f WHIRLPOOL ba116eafe5304f8896c510ffd1e42a90e34851ca367e8c82d3570ac7186d63ebca07151e565f8ebfdd33aad16e82698a37aed6f3ce0b679ca4f25e864243d010
DIST puppet-agent_1.5.1-1xenial_amd64.deb 12981352 SHA256 71bd54296485aeee7bb2e6851904907cee3f31114efa497bf9e999c3a3f15148 SHA512 eabe78c021d70cfea37343daa92b0cb1b1a342c6b8a59e16f83b81d2db8b36e251c44aae7ccd1d6284371e1e50e96ce3d410f1b4481d3f4202ea5904a594a917 WHIRLPOOL dbedf532027091f239bca4eac0fbcb8fb137f76dadc6c0172ceca67a55ef74948a009c978893713277931969d42ef42d6e4bb724490c0b7e67e9eabb0b9f783c
DIST puppet-agent_1.5.1-1xenial_i386.deb 14023324 SHA256 94509aaa5f03be6e1a73d99585520638f50a582c71d8cfa8432c4f2509907ce4 SHA512 f6c489eec7336388a4ba3ea1c3bcb36e35958b1b1062e9dd4419a68337fbdc2490d775d692830c97fba35a70fbb4c2cb69173643d13a931d011c5b5faf06eff2 WHIRLPOOL 26e4f587af78f3a3bcbb5898416d2aafdb4f1fccf73eb8cab2edf955c8f7a574ea293fc2af97dac9baa7ac8c68593ea9d8981cdff7fda4240647585a4de8061c
+DIST puppet-agent_1.5.2-1xenial_amd64.deb 12979184 SHA256 917c4dfccf6ac08ab62965262738927d8e50345fe1c9e58e91a8c8b8a0a82b3c SHA512 d662ca7a3c4c3ed0ce83c8b3de5aa862504ec44c7d3b18211aa46cca441b73e5b9929584b436ae2bf8d25b04badbb14af45a1f83a27fd9593cc961345235169e WHIRLPOOL 293a8818df6fade05a3a439f4e77b5d884aa6a9f6a0f0798883455c95332782467df640915d48c29fdd63b18708415376cece4f0633cbc22d333a06782260164
+DIST puppet-agent_1.5.2-1xenial_i386.deb 14019620 SHA256 b5220616f12408a422ca65f0bab8bfeeb7dab026448c3141d3afe54f4e455899 SHA512 59611a7d4faa75b16dd492f14da3bacb5b50722b773bdd882d7be08e576462412f5aacb7f247492869048e7d1290824652b37b3ba088ca27da08306bb3137f54 WHIRLPOOL b5757c879ca6a2ecb9e9656ca899eabbeb34af3ce93bc078ed9ac41a601a65f1a2a5b4e738b282c7d1e469e2c63df67072a7ea63c7826340da3227ab24816cf7
diff --git a/app-admin/puppet-agent/puppet-agent-1.5.2.ebuild b/app-admin/puppet-agent/puppet-agent-1.5.2.ebuild
new file mode 100644
index 000000000000..a60350d84b91
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.5.2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}