summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-08-02 21:04:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-08-02 21:05:20 -0500
commit8654f8470ff2f4aaf1cb5f8c42e54ef8c3d3b7ac (patch)
tree36beb795b31122580633afc7b04d042c987ff1cc /app-admin/puppet-agent
parentmetadata/install-qa-check.d: skip 60python-pc if gpep517 too old (diff)
downloadgentoo-8654f8470ff2f4aaf1cb5f8c42e54ef8c3d3b7ac.tar.gz
gentoo-8654f8470ff2f4aaf1cb5f8c42e54ef8c3d3b7ac.tar.bz2
gentoo-8654f8470ff2f4aaf1cb5f8c42e54ef8c3d3b7ac.zip
app-admin/puppet-agent: 7.18.0 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.18.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index b48ee2d319be..c846576aa296 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -2,3 +2,5 @@ DIST puppet-agent_7.16.0-1focal_amd64.deb 20349200 BLAKE2B 73a5bc404b988fc009b95
DIST puppet-agent_7.16.0-1focal_arm64.deb 19543124 BLAKE2B 2a946462ddf1344f05f21c5c5f0a3ad4a1b92fa0b386d405b6cb563b0cb3de0a06ad8212d6001f10ed7afe2d7787d1107732a5890e48de99a32cec802d78d16d SHA512 74db9defefe8aa91daaac8337dd500cf2582c017eab34f61992630a30dc9b2ef62ae5aba21b9ee94f30b6f92e99557e61da742711bba7df8200b3eca5a06f748
DIST puppet-agent_7.17.0-1focal_amd64.deb 20397624 BLAKE2B 8304f937e6eb3f1a3c2a72ba34fce029ecec99decaf1a78b08b556c1ebe3073fa159e70e43baf468e833ede2e9a659f6384f52969e16932ac24a2a997da14eee SHA512 f493298af50e6eed61c7ffb0cf4234b1eb69594caedd24826bc9bcb5d85e736101bfa98b14dcfdceab5ee98e8bc228f25743fdcce440398ff9e0019c6861bde2
DIST puppet-agent_7.17.0-1focal_arm64.deb 19595304 BLAKE2B 719473363cb24dcd58a864c9ce4d24cb8d8f328d6179ec666d3f3ba1dbf8df53746b9dba37a820c782b6b7b56639c068da1a7db4813e44c5520dfc74ff026008 SHA512 5d74f2fca8fe214c70931b099582d5861ae95a3f11be69e33ee4a10b5135cde43d57b117fa3492983b13e023f9138584d72df6ea788015e058124e4578ae1e39
+DIST puppet-agent_7.18.0-1focal_amd64.deb 33767214 BLAKE2B def38171c1e0cad50cdffc8aada569af0996b1b7e3f788ffa3c5e3b05d0456d2776f2d12a4cf2f8a9227ebf3c1c13b52fa28f210249b04a54de1fbbc19f26c30 SHA512 387d3e1ca3a05c107411dc7a126b2984e8dacf3580823022c0010f33b08305b6722d8a1babee7825b8f60769589b1f166991931f66a484d94a17ac7d437141e1
+DIST puppet-agent_7.18.0-1focal_arm64.deb 33559710 BLAKE2B af2a4657c95dc7208b5c2f7494b9cec03f1c9ed0e73c06c150f492fa474d5620f5a58b23b7d928d4117a9b2b8c6384514b7f7000e7a6639582ebe97ab82571a7 SHA512 fafabbd00c4ef03b3bd6d9680bc78ada42ffefa8bc8186f24203be277e01267363f0ff35f176f3f04057c46ff437bbb957d4416ce5b6ffc1b3e1f79492c2ce7b
diff --git a/app-admin/puppet-agent/puppet-agent-7.18.0.ebuild b/app-admin/puppet-agent/puppet-agent-7.18.0.ebuild
new file mode 100644
index 000000000000..0776db0b3b8b
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-7.18.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="amd64? ( http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb )
+arm64? ( http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_arm64.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+# virtual/libcrypt:= is in here despite being a pre-built package
+# to ensure that the has_version logic for the symlink doesn't become stale
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet
+ virtual/libcrypt:="
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt[compat]
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+
+ # Handling of the path to the crypt library during the ongoing migration
+ # from glibc[crypt] to libxcrypt
+ # https://www.gentoo.org/support/news-items/2021-07-23-libxcrypt-migration.html
+ if has_version "sys-libs/glibc[crypt]"; then
+ local crypt_target='../../../../usr/lib64/xcrypt/libcrypt.so.1'
+ else
+ local crypt_target='../../../../usr/lib/libcrypt.so.1'
+ fi
+ dosym $crypt_target /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}
+
+pkg_postinst() {
+ tmpfiles_process puppet-agent.conf
+}