summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-23 09:38:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-23 09:38:17 -0500
commit997ec0237f7a3425eab9b5130f883095a709cd95 (patch)
tree6c6c96bbb9b90f9c1ddddcadd960a7339c584e58 /app-admin/puppet-agent
parentnet-irc/irssi: Stable for HPPA PPC64 (bug #594724). (diff)
downloadgentoo-997ec0237f7a3425eab9b5130f883095a709cd95.tar.gz
gentoo-997ec0237f7a3425eab9b5130f883095a709cd95.tar.bz2
gentoo-997ec0237f7a3425eab9b5130f883095a709cd95.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.7.0.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 0067dc7fa909..c442b0839bbc 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,2 +1,4 @@
DIST puppet-agent_1.6.2-1xenial_amd64.deb 13882068 SHA256 e4921a53f71bb16d9b19b261d1cf415d2be03ae8e8605a36037d080e1fd928e3 SHA512 1621c1458a973a39104a6a5750ee02bb50cbaab2010097db9a4e0e7a668576c93012ac7c1408c470bc6debfda2bbd15e147e852cc0b944619c49879bd3b676d8 WHIRLPOOL 6dbedd797a0fc8503176103f6992af76898663f059412816fdeeb2780c7142538c26c31e300dee593b6b9efd4fd6173eddfcae3dec1ae5975e27daaf1169ccd2
DIST puppet-agent_1.6.2-1xenial_i386.deb 15231484 SHA256 b58a9e73df92181700183a32803f01d00dff8d7b5d8565ec1cc512a850301f79 SHA512 8ddbb5e7da0cb94e3948c3d993fda364b5f6cb22514218d02df685826658d5649d066e4121881d0ea4b7d17b524d26df140915ef158b86c5a134ca3ee3206148 WHIRLPOOL 64173df8aad4056621252e9d9cbc5f04cd18753377e80d1fe663478518d10484d48cc162d213e4ad0f535c4c23626cb32166f5896624e8772899acb05325152d
+DIST puppet-agent_1.7.0-1xenial_amd64.deb 13880620 SHA256 804cce57baca64f50d1f78a1fa2b7668aec99a78ea4d19e12935f1c9811c44b6 SHA512 2414a42c86a84ab3235b99a6e824bcbd93b432572a64e7faab29ca9b027da27aefd168d060f9bac73663639cbf5213a74bb14e152a60a307efea6704a183424b WHIRLPOOL 1fec15a704f1a836bca4fc58dbb369b3e5e6c171f998a08e78ba642c96b9cce84de0bb22435c230038714f4b7be405154856ebb39aa96a7733b7c8f02974c587
+DIST puppet-agent_1.7.0-1xenial_i386.deb 15233100 SHA256 bb602489cff71e228496b819242dde362f6486290ef60ff500025294dfb072ff SHA512 720572147d4808045960ab630ab23b7de9ea0eb6d0c388c0ad814eebc07fbe466bf7161c9d357e4562a0a92a41e348f7cf247364acae63f831787b3e0daa3de2 WHIRLPOOL 0dd236d25d99e9aa5c5c3611568fc42945e537b4e9f65e89e7b8b27aa48b64e9a9108e682adcb71982b101f8ccfb78abe695e66f9d850cdba9b13439f9d655ef
diff --git a/app-admin/puppet-agent/puppet-agent-1.7.0.ebuild b/app-admin/puppet-agent/puppet-agent-1.7.0.ebuild
new file mode 100644
index 000000000000..a60350d84b91
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.7.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/xenial/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1xenial"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}