summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-02 10:42:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-02 10:46:36 -0500
commita108435a88b79f840be80327e1e25c1c5da81fae (patch)
tree1fca3b97d32c55eeddf278c08ac5d60b7a0b911d /app-admin/puppet-agent
parentapp-admin/puppet: 7.7.0 bump (diff)
downloadgentoo-a108435a88b79f840be80327e1e25c1c5da81fae.tar.gz
gentoo-a108435a88b79f840be80327e1e25c1c5da81fae.tar.bz2
gentoo-a108435a88b79f840be80327e1e25c1c5da81fae.zip
app-admin/puppet-agent: 7.7.0 bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest1
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.7.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index f939ecc2f66b..cf9b09a905fb 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,3 +1,4 @@
DIST puppet-agent_6.19.1-1focal_amd64.deb 22221600 BLAKE2B 22b03ef1f86b34955e8bad7c63a2022d2832dadd554316baf75419d6543e8a569902fb92a81a3dcc817401f06aa7dd47143a6cbd383f0e531c465cd3203dc4ed SHA512 4819a3509066516b0be76bc0f2afe94611405f7ac52fe50890d57c86a8a9c6c70787d46cb4b77085666f3e74bcb83a11acf1fef5d1e6ed3151ea06cbb8df3170
DIST puppet-agent_7.5.0-1focal_amd64.deb 20900560 BLAKE2B a1f0e3da38cc98e677f66fd8887e4db1e1bd9d2af0b89597c0b1f2e569b78ccd8eb2d7c84c9cf5c8d03097dd6b22ae323ad7e9f989b06692a6ca7fbd28d5cf46 SHA512 250839f7d4a09545ae509273cbfb1ba004b8d0c5559b5312642b7483c605d32b7575c52b5e9a2b9d3f65e2fcfbf00f4ed85ee498ae9dc39629f1618aaab79361
DIST puppet-agent_7.6.1-1focal_amd64.deb 20894772 BLAKE2B 235f62750c1e7a42b8b4fa013b969926c4c168fd6a6d9cfc8f243ef5571360593572faad57326019c09cd1d1e67fcc985d699acbd07c3279ac350712828eb26f SHA512 36b9f69cbef0b51a80375231472e4bab195a08b14bb860419d2ad01f13d90cba377d796b3253643f77ff415f43d2f9598dc18c37d76d844a3ea98299e5d43e65
+DIST puppet-agent_7.7.0-1focal_amd64.deb 20917640 BLAKE2B f0b154c49f083a0eba5caa9351c83534a3fcce9028d56ed7c2a9c58520c5105eab215432aab0ac188b6ccaa11d922a90bed2b093a3234ec292d80c12f8e1f188 SHA512 70375495d08eccd145fa936118341c861cad76c1b760055579814d9d79d424db1b165d884bbca20dd3ce3bf932a9d99043ef38f968318bd028b6f1b3750eeeef
diff --git a/app-admin/puppet-agent/puppet-agent-7.7.0.ebuild b/app-admin/puppet-agent/puppet-agent-7.7.0.ebuild
new file mode 100644
index 000000000000..4a86bc593571
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-7.7.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd unpacker tmpfiles
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet"
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ newtmpfiles usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../../../usr/lib64/xcrypt/libcrypt.so.1 /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}