summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-02-09 16:52:29 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-02-09 16:52:52 -0600
commitded9f5cdcbf653f77985b21a598cb4910e86ec74 (patch)
tree1987c06b6ce06b49e3d0434f9974619f37681c52 /app-admin/puppet-agent
parentapp-admin/puppetserver: 7.0.3 bump with 7.0.1/2 removal (diff)
downloadgentoo-ded9f5cdcbf653f77985b21a598cb4910e86ec74.tar.gz
gentoo-ded9f5cdcbf653f77985b21a598cb4910e86ec74.tar.bz2
gentoo-ded9f5cdcbf653f77985b21a598cb4910e86ec74.zip
app-admin/puppet-agent: 7.4.0 bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet-agent')
-rw-r--r--app-admin/puppet-agent/Manifest1
-rw-r--r--app-admin/puppet-agent/puppet-agent-7.4.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index ccb839196443..282d6ad1acd6 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -1,3 +1,4 @@
DIST puppet-agent_6.19.1-1focal_amd64.deb 22221600 BLAKE2B 22b03ef1f86b34955e8bad7c63a2022d2832dadd554316baf75419d6543e8a569902fb92a81a3dcc817401f06aa7dd47143a6cbd383f0e531c465cd3203dc4ed SHA512 4819a3509066516b0be76bc0f2afe94611405f7ac52fe50890d57c86a8a9c6c70787d46cb4b77085666f3e74bcb83a11acf1fef5d1e6ed3151ea06cbb8df3170
DIST puppet-agent_7.1.0-1focal_amd64.deb 20881084 BLAKE2B 1f16533e9f2da9971bfeaaab696bd0631d058928491c52e7cadba2c710af8373cfb89b4eaa4e293121857dfdad9bc694d562ebd9db8213198191c56fe94dd119 SHA512 3356810dd08baad373fd62669995cea17fed6baad3d3ae54dfd00c88a69602b5d4b8917b5e54aacc41fbd011a4e6877d1fd6c4a62d09648ddfaf26d898c3e7d6
DIST puppet-agent_7.3.0-1focal_amd64.deb 20876192 BLAKE2B 2d7b9925771c31204f4fe12253ccff0fb68fb1c475856c31b1bf82b4c1ef3f93870660916702e9acfe57235a4293d7807c24f80789310bc4efb9784c86e895c5 SHA512 79c72664795c37fe0bbcc0d96116ff073cc07154b5713a904602308e3fadb37bc1bba04466bd29877340e0d7707475f3cc38348e1811660764d18ed3c1d53250
+DIST puppet-agent_7.4.0-1focal_amd64.deb 20897448 BLAKE2B 1ed2ad91dcba1851b5759591033cfd74ec9dc644b3da416f2c1f5598b89e7cfa1048f09331717fc2b72a479ae8a7137f8f0a074debfbc183aea1197ae31b5df4 SHA512 bd58032f38f349938843550bc1e238f1cadec685ab6f90969e12e47e021fcdf4ffd4aa7be98fd797976d7873045444ba20b4ad3d05f543897a8d3594949c55f4
diff --git a/app-admin/puppet-agent/puppet-agent-7.4.0.ebuild b/app-admin/puppet-agent/puppet-agent-7.4.0.ebuild
new file mode 100644
index 000000000000..8a6e3a65de40
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-7.4.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1focal_amd64.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ app-emulation/virt-what
+ acct-user/puppet
+ acct-group/puppet"
+
+DEPEND="
+ ${CDEPEND}
+ app-admin/augeas"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/libselinux
+ sys-libs/glibc
+ sys-libs/readline:0/8
+ sys-libs/libxcrypt
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ keepdir var/log/puppetlabs/puppet/
+ chmod 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd2" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd usr/lib/tmpfiles.d/puppet-agent.conf puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../../../usr/lib64/xcrypt/libcrypt.so.1 /opt/puppetlabs/puppet/lib/libcrypt.so.1
+}