summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-09-28 06:16:07 +0200
committerHans de Graaff <graaff@gentoo.org>2017-09-28 06:16:07 +0200
commitba80d823063ce519ed0751399e8c31b0f5e8f3a9 (patch)
tree84559d2b3d6dcd79dc269b1b9d416a7b35885c80 /app-admin/puppet-lint/puppet-lint-2.3.2.ebuild
parentdev-ruby/rspec-json_expectations: add ruby24 (diff)
downloadgentoo-ba80d823063ce519ed0751399e8c31b0f5e8f3a9.tar.gz
gentoo-ba80d823063ce519ed0751399e8c31b0f5e8f3a9.tar.bz2
gentoo-ba80d823063ce519ed0751399e8c31b0f5e8f3a9.zip
app-admin/puppet-lint: add 2.3.2
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'app-admin/puppet-lint/puppet-lint-2.3.2.ebuild')
-rw-r--r--app-admin/puppet-lint/puppet-lint-2.3.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/puppet-lint-2.3.2.ebuild b/app-admin/puppet-lint/puppet-lint-2.3.2.ebuild
new file mode 100644
index 000000000000..65e7f40bb291
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-2.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit eutils ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}