summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-07-09 06:03:33 +0200
committerHans de Graaff <graaff@gentoo.org>2018-07-09 06:03:33 +0200
commit91a8186552671a1a3b5a6581856a8ecda8f9c7a5 (patch)
tree95fa2a9af5880b7d5a5f7d0e107b1ea2bf4091e8 /app-admin/puppet-lint/puppet-lint-2.3.6.ebuild
parentdev-ruby/rgen: amd64 stable (diff)
downloadgentoo-91a8186552671a1a3b5a6581856a8ecda8f9c7a5.tar.gz
gentoo-91a8186552671a1a3b5a6581856a8ecda8f9c7a5.tar.bz2
gentoo-91a8186552671a1a3b5a6581856a8ecda8f9c7a5.zip
app-admin/puppet-lint: add 2.3.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-admin/puppet-lint/puppet-lint-2.3.6.ebuild')
-rw-r--r--app-admin/puppet-lint/puppet-lint-2.3.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/puppet-lint/puppet-lint-2.3.6.ebuild b/app-admin/puppet-lint/puppet-lint-2.3.6.ebuild
new file mode 100644
index 000000000000..c86bd234ccc4
--- /dev/null
+++ b/app-admin/puppet-lint/puppet-lint-2.3.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit eutils ruby-fakegem
+
+DESCRIPTION="A linter for puppet DSL"
+HOMEPAGE="http://puppet-lint.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-its:1
+ dev-ruby/rspec-collection_matchers:1
+ dev-ruby/rspec-json_expectations )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}