summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-24 10:23:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-24 10:30:43 -0500
commit1a5cfacbb0c0f7bf0eb2b3464311f25aa3bd3dc2 (patch)
tree922cd1e8f340d7420a5ec821b8aaa077e5c0f6e9 /app-admin/puppet
parentmedia-gfx/inkscape: Attempt to avoid MAKEOPTS="-j1" (diff)
downloadgentoo-1a5cfacbb0c0f7bf0eb2b3464311f25aa3bd3dc2.tar.gz
gentoo-1a5cfacbb0c0f7bf0eb2b3464311f25aa3bd3dc2.tar.bz2
gentoo-1a5cfacbb0c0f7bf0eb2b3464311f25aa3bd3dc2.zip
app-admin/puppet: 6.7.0 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-6.7.0.ebuild138
2 files changed, 139 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index ebaa8942acde..1c2c2e26fe76 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -2,3 +2,4 @@ DIST puppet-4.10.12.tar.gz 3022218 BLAKE2B 03757857868b1544078ae5e40d6e438631c78
DIST puppet-5.5.14.tar.gz 3075736 BLAKE2B bfea82d40f9671cdefab0b10c9481e4fbad397dd0a4aa26f5d0fa9ffa94477a5cc59b3724ab9ae3ee2e7e9230881676582c328c804ce9138dc484b9bd92e0ec3 SHA512 861100c02e0b8a5bb232d266bcd5e54b0e32cf26954ea37f276690aa3159ffdb28195ab8691df61ee0098300d226ea1d369dbdff8aae69101c2bbe6068ede8b1
DIST puppet-6.4.2.tar.gz 2891159 BLAKE2B dfd8e5d9935d54272096fac66a037b8eab75dedc42caf18bafe29738e749a66869ad2e741753e8b38d872e21b1a261f2b4017c54faa57043754d619cf27652ed SHA512 7ec2746ef2a021d1cc3e3076840a9f1195fe51ba591cf2907e542b3f450cb1f4002fa3c958aee966c5976245073ba3cfacc9fd2a653d1d823720b33984aff911
DIST puppet-6.6.0.tar.gz 2898687 BLAKE2B 67370b191985f75f783d795d7ef38df53fbf28efa8ab79ae309dba985f4ba296d2862fb366b68a46d03f526c3f27c51b1e1cefcccbaa96f6694dc888a7adcc2c SHA512 e7e7367565d12c208654bd353112542fb84b736f262dc86adb940e02a4e34d473e7bb5f084e0caa5fab01be4ef479ad2baa3e751d4d86ee447cf960f400413e5
+DIST puppet-6.7.0.tar.gz 2904053 BLAKE2B ce697b8ae97bcb4337c4ccec6e1d473709e0aadbe5c77bf451289ea7d69039eaf76dd82a949f984acd871f79adf1ba5000ddec85c483e80b6eab3f24e53ed3e1 SHA512 3d34d678b075d8ccf3e365eaf7a5d5c337426e6f6a8acc0c834852ab4c59596d5841e181e629a233a24335365ba5c080feded154c170714c05fc76beda190a59
diff --git a/app-admin/puppet/puppet-6.7.0.ebuild b/app-admin/puppet/puppet-6.7.0.ebuild
new file mode 100644
index 000000000000..0038f1ebf433
--- /dev/null
+++ b/app-admin/puppet/puppet-6.7.0.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit eutils user ruby-fakegem eapi7-ver
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="https://puppet.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ dev-ruby/semantic_puppet
+ >=dev-ruby/facter-3.0.0
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # can't be run within portage.
+ epatch "${FILESDIR}/puppet-fix-tests-6.4.1.patch"
+
+ # fix systemd path
+ epatch "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+ elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
+ elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
+ elog "not already done so."
+ elog
+}