summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-14 16:07:52 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-14 16:13:21 -0600
commit416e4e098800a5d97dc820f1852ffa0ef132e969 (patch)
treee54f0e8b2cb52439f764611d5c77b422a1f08336 /app-admin/puppet
parentmedia-plugins/gst-plugins-libav: remove old (diff)
downloadgentoo-416e4e098800a5d97dc820f1852ffa0ef132e969.tar.gz
gentoo-416e4e098800a5d97dc820f1852ffa0ef132e969.tar.bz2
gentoo-416e4e098800a5d97dc820f1852ffa0ef132e969.zip
app-admin/puppet: 5.4.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-5.4.0.ebuild147
2 files changed, 148 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 863d223c947e..ab0ef628c02e 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -2,3 +2,4 @@ DIST puppet-4.10.10.tar.gz 2995864 BLAKE2B c01e6a7529d70a4481e64b4119cfd9d05e79d
DIST puppet-4.10.8.tar.gz 2979824 BLAKE2B 802b65d48ff7d8303e3cc847a9f753a5e19c0ada6ee02dc1fc9c748da8d69462c34bdfeddeedf0057179ff1133665439c41e970c41ca1728463292ef26e996ab SHA512 9f3384702dd4938e1e00aeceb0745b760de32000e0dd59d5b846d1120a46026499176a51d0409e3a0ae414efc0872854c204d1941385695a4c57c209fbd1f28d
DIST puppet-5.3.4.tar.gz 2889645 BLAKE2B f1f4e2d9dfe457f89aa7d99724eaa9368ea50027747e2506b5cbfa176c1a9060bf87ce8c037b78f3c86c2e2974087f9ab4fc76cb7374f1a348ff410e9cfa83e1 SHA512 f24008651be15cf5c915f7a03dc0319eb2d076ddfb06c44fd846421fe29baba27ea43b29134077e1dc7c14a48b44104dcaaefe73bfdb00d7667c1c25a1b871fd
DIST puppet-5.3.5.tar.gz 2890869 BLAKE2B 1baeddbaa47803811e14bfdbbf5624b617ced2ec6ec6b8072d51a556455838bf0934b1e0c578ef6b4d5df763260c0fa0f027295e3c8403c172a25fcc72179283 SHA512 d48b836a9c7db451c73048917e091a1dd3e1c259f4dde7a8867fe9931d9dbab46219f4b4dfa739669bb8d713a9defe13eae0d5b2dd26a6930b589f4cb0ab1361
+DIST puppet-5.4.0.tar.gz 2958138 BLAKE2B 2cb7e890774abde7183a7b3ac33771fe8006f526b7780a566788591cba20c1ff7540429a4ead13830700fc07105fdaec4317de69f4efa44c4b245b31164b6048 SHA512 6b6955416e4f14ba45318c1afce7db77226da2d14f8dbfeca059780caf188f9687bf31dff4a4c57f8172468e09c35e021721a8b8caf99050d72f90b290fbdb71
diff --git a/app-admin/puppet/puppet-5.4.0.ebuild b/app-admin/puppet/puppet-5.4.0.ebuild
new file mode 100644
index 000000000000..1f8461b191db
--- /dev/null
+++ b/app-admin/puppet/puppet-5.4.0.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit eutils user ruby-fakegem versionator
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ >=dev-ruby/facter-3.0.0
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # can't be run within portage.
+ epatch "${FILESDIR}/puppet-fix-tests-4.7.0.patch"
+
+ # fix systemd path
+ epatch "${FILESDIR}/puppet-systemd.patch"
+
+ # backport upstream fix for ruby 2.3.6 compatibility
+ epatch "${FILESDIR}/puppet-4-webrick-ruby.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+ newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+
+ for v in ${REPLACING_VERSIONS}; do
+ if [ "$(get_major_version $v)" = "4" ]; then
+ elog
+ elog "Please see the following url for the release notes for puppet-5"
+ elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
+ elog
+ fi
+ done
+}