summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-05-14 10:44:59 -0700
committerSam James <sam@gentoo.org>2022-05-15 00:05:31 +0000
commit1843f84e6b30d338ad004baed919ef6313fe0e4f (patch)
tree6f4133ffc4a992a6c81d997eff02d8b57d39114c /app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch
parentprofiles: mask USE=rdma on mips, rdma-core not keyworded (diff)
downloadgentoo-1843f84e6b30d338ad004baed919ef6313fe0e4f.tar.gz
gentoo-1843f84e6b30d338ad004baed919ef6313fe0e4f.tar.bz2
gentoo-1843f84e6b30d338ad004baed919ef6313fe0e4f.zip
app-admin/radmind: Fix build with cyrus-sasl
When radmind is build while cyrus-sasl is installed on the system the libsnet submodule will enable it and then radmind will fail to compile with undefined refererenes for sasl. This was caused by my earlier patches that accidentally dropped that part in radmind that disabled sasl support during the libsnet configure process. I also added missing dependencies and USE flags. Bug: https://bugs.gentoo.org/844160 Upstream-PR: https://github.com/Radmind/radmind/pull/336 Upstream-PR: https://github.com/voretaq7/radmind/pull/1 Upstream-PR: https://sourceforge.net/p/libsnet/patches/7/ Fixes: https://github.com/gentoo/gentoo/commit/601775bd1dbb2e6f87c8eb39bee18a8964324e22 Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch')
-rw-r--r--app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch109
1 files changed, 109 insertions, 0 deletions
diff --git a/app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch b/app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch
index 211342d0bd83..a33003b33424 100644
--- a/app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch
+++ b/app-admin/radmind/files/radmind-1.15.4-autoreconf-libsnet.patch
@@ -165,3 +165,112 @@ index 0000000..88a421b
--
2.35.1
+From 4ea29130382b5ae8b9cf3e3dc8962da764f65377 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Fri, 13 May 2022 13:41:49 -0700
+Subject: [PATCH 2/2] Add AC_ARG_ENABLE options for ssl, sasl and zlib
+
+---
+ configure.ac | 83 +++++++++++++++++++++++++++++++++++++++++-----------
+ 1 file changed, 66 insertions(+), 17 deletions(-)
+
+diff --git a/libsnet/configure.ac b/libsnet/configure.ac
+index 83f7e59..9cd16c7 100644
+--- a/libsnet/configure.ac
++++ b/libsnet/configure.ac
+@@ -11,26 +11,75 @@ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_INSTALL
+
+-PKG_CHECK_MODULES([zlib], [zlib],
+- [AC_DEFINE([HAVE_ZLIB], [1], [zlib])],
+- [AC_MSG_WARN(zlib.pc not found, building without zlib support)])
+-AC_SUBST([zlib_LIBS])
+-AC_SUBST([zlib_CFLAGS])
++# Enable features
++AC_ARG_ENABLE([sasl],
++ AS_HELP_STRING([--enable-sasl], [Build with crypto_sasl @<:@default=yes@:>@]),
++ [AS_CASE(${enableval}, [yes], [], [no], [],
++ [AC_MSG_ERROR([bad value '${enableval}' for --enable-sasl])])],
++ [enable_sasl=check])
+
+-# Checks for libraries.
+-if test \! x_$with_ssl = x_no; then
+- PKG_CHECK_MODULES([ssl], [openssl],
+- [AC_DEFINE([HAVE_LIBSSL], [1], [libssl])],
+- [AC_MSG_WARN(openssl.pc not found, building without libssl support)])
+- AC_SUBST([ssl_LIBS])
+- AC_SUBST([ssl_CFLAGS])
+-fi
++AC_ARG_ENABLE([ssl],
++ AS_HELP_STRING([--enable-ssl], [Build with openssl @<:@default=yes@:>@]),
++ [AS_CASE(${enableval}, [yes], [], [no], [],
++ [AC_MSG_ERROR([bad value '${enableval}' for --enable-ssl])])],
++ [enable_ssl=check])
+
+-PKG_CHECK_MODULES([sasl], [libsasl2],
+- [AC_DEFINE([HAVE_LIBSASL], [1], [libsasl])],
+- [AC_MSG_WARN(libsasl2.pc not found, building without libsasl support)])
+-AC_SUBST([sasl_LIBS])
++AC_ARG_ENABLE([zlib],
++ AS_HELP_STRING([--enable-zlib], [Build with zlib @<:@default=yes@:>@]),
++ [AS_CASE(${enableval}, [yes], [], [no], [],
++ [AC_MSG_ERROR([bad value '${enableval}' for --enable-zlib])])],
++ [enable_zlib=check])
++
++# Checks for crypto_sasl.
++AS_IF([test x$enable_sasl != xno],
++ [PKG_CHECK_MODULES([sasl], [libsasl2],
++ [AC_DEFINE([HAVE_LIBSASL], [1], [libsasl])],
++ [AS_IF([test x$enable_sasl != xyes],
++ [AC_MSG_WARN([cannot find libsasl2.pc, disabling libsasl support])],
++ [enable_sasl=error])
++ ])
++ ])
++
++AS_IF([test x$enable_sasl = xerror],
++ [AC_MSG_ERROR([cannot find libsasl2.pc and libsasl support requested])])
++
++AM_CONDITIONAL([ENABLE_LIBSASL], [test x$enable_sasl = xyes])
+ AC_SUBST([sasl_CFLAGS])
++AC_SUBST([sasl_LIBS])
++
++# Checks for openssl.
++AS_IF([test x$enable_ssl != xno],
++ [PKG_CHECK_MODULES([ssl], [openssl],
++ [AC_DEFINE([HAVE_LIBSSL], [1], [libssl])],
++ [AS_IF([test x$enable_ssl != xyes],
++ [AC_MSG_WARN([cannot find openssl.pc, disabling libssl support])],
++ [enable_ssl=error])
++ ])
++ ])
++
++AS_IF([test x$enable_ssl = xerror],
++ [AC_MSG_ERROR([cannot find openssl.pc and libssl support requested])])
++
++AM_CONDITIONAL([ENABLE_LIBSSL], [test x$enable_ssl = xyes])
++AC_SUBST([ssl_CFLAGS])
++AC_SUBST([ssl_LIBS])
++
++# Checks for zlib.
++AS_IF([test x$enable_zlib != xno],
++ [PKG_CHECK_MODULES([zlib], [zlib],
++ [AC_DEFINE([HAVE_ZLIB], [1], [zlib])],
++ [AS_IF([test x$enable_zlib != xyes],
++ [AC_MSG_WARN([cannot find zlib.pc, disabling zlib support])],
++ [enable_zlib=error])
++ ])
++ ])
++
++AS_IF([test x$enable_zlib = xerror],
++ [AC_MSG_ERROR([cannot find zlib.pc and zlib support requested])])
++
++AM_CONDITIONAL([ENABLE_ZLIB], [test x$enable_zlib = xyes])
++AC_SUBST([zlib_CFLAGS])
++AC_SUBST([zlib_LIBS])
+
+ # Checks for header files.
+ #AC_HEADER_STDC
+--
+2.35.1
+