summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/recursos
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/recursos')
-rw-r--r--app-admin/recursos/Manifest1
-rw-r--r--app-admin/recursos/metadata.xml11
-rw-r--r--app-admin/recursos/recursos-2.0.ebuild58
3 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/recursos/Manifest b/app-admin/recursos/Manifest
new file mode 100644
index 000000000000..2cf42ccc9c66
--- /dev/null
+++ b/app-admin/recursos/Manifest
@@ -0,0 +1 @@
+DIST recursos-2.0.tbz2 29480 SHA256 031e2b2cae9c86ce828b609c30ca24d32ddcfa13c53b15f35388ad9da6ec1520 SHA512 391bd253b62cbc2afbf054baa368bef5f7847624889188829557244f132bf484d4d4652a8c524da95ae3b39909fbdc37796eb325839bcd5e8982f7dcb6cd89e4 WHIRLPOOL 696de8f5c5d205d21630aa5ee95818d12c313d53b65e63d6b69defa41c38d0e5b63f72c067b4535690f41ead9cd4e74b12b7c89605d9b25fd487041a7fb03cf2
diff --git a/app-admin/recursos/metadata.xml b/app-admin/recursos/metadata.xml
new file mode 100644
index 000000000000..73490c4cea00
--- /dev/null
+++ b/app-admin/recursos/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A set of script to extrac usefull info about your system and report it
+ in plain text or html. It can generate Grpahs using rrdtools.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/recursos/recursos-2.0.ebuild b/app-admin/recursos/recursos-2.0.ebuild
new file mode 100644
index 000000000000..b22333e174d2
--- /dev/null
+++ b/app-admin/recursos/recursos-2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Script to create html and text report about your system"
+HOMEPAGE="http://www.josealberto.org"
+SRC_URI="mirror://gentoo/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ app-shells/bash
+ net-analyzer/rrdtool[graph]"
+
+S=${WORKDIR}/r2
+
+src_install() {
+ WWWDIR="/var/www/localhost/htdocs/R2"
+
+ insinto /etc
+ doins recursos2.conf
+
+ dobin R2createrrd.sh R2generarrd.sh R2updaterrd.sh Recursos2.sh
+
+ dodir ${WWWDIR}
+ insinto ${WWWDIR}
+ doins R2/*.html
+
+ dodir ${WWWDIR}/common
+ insinto ${WWWDIR}/common
+ doins R2/common/*
+
+ dodir ${WWWDIR}/rrd/mini
+}
+
+pkg_postinst() {
+ elog "Fist you must configure /etc/recursos2.conf"
+ elog "Then follow these steps:"
+ elog
+ elog "1. Run R2createrrd.sh"
+ elog
+ elog "2. Add crontab jobs (this is an example):"
+ elog "*/2 * * * * root /usr/bin/R2updaterrd.sh"
+ elog "*/5 * * * * root /usr/bin/R2generarrd.sh"
+ elog "*/10 * * * * root /usr/bin/Recursos2.sh \ "
+ elog " title general system disks net \ "
+ elog " > /var/www/localhost/htdocs/recursos.html"
+ elog
+ elog "You can use Recursos2.sh to extract info about your system"
+ elog "in html or plain text and mail the file or whatever."
+ elog
+}