summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2020-05-13 00:21:04 -0500
committerMarc Schiffbauer <mschiff@gentoo.org>2020-05-13 00:22:06 -0500
commit872acae5dc5cdfcbc14273736b779142610193c2 (patch)
tree44c6cb478d07e58d4396b486c418a5829892a3d7 /app-admin/restart-services/restart-services-0.15.1.ebuild
parentdev-ruby/mime-types-data: add 3.2020.0512 (diff)
downloadgentoo-872acae5dc5cdfcbc14273736b779142610193c2.tar.gz
gentoo-872acae5dc5cdfcbc14273736b779142610193c2.tar.bz2
gentoo-872acae5dc5cdfcbc14273736b779142610193c2.zip
app-admin/restart-services: bump version
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'app-admin/restart-services/restart-services-0.15.1.ebuild')
-rw-r--r--app-admin/restart-services/restart-services-0.15.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/restart-services/restart-services-0.15.1.ebuild b/app-admin/restart-services/restart-services-0.15.1.ebuild
new file mode 100644
index 000000000000..874ac8f35520
--- /dev/null
+++ b/app-admin/restart-services/restart-services-0.15.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tool to manage OpenRC services that need to be restarted"
+HOMEPAGE="https://dev.gentoo.org/~mschiff/restart-services/"
+SRC_URI="https://dev.gentoo.org/~mschiff/src/${PN}/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-admin/lib_users
+ sys-apps/openrc
+ app-portage/portage-utils
+"
+
+src_install() {
+ dosbin restart-services
+ doman restart-services.1
+ keepdir /etc/restart-services.d
+ insinto /etc
+ doins restart-services.conf
+ dodoc README CHANGES
+
+ sed -i 's/^#include/include/' "${D}"/etc/restart-services.conf
+ cat>"${D}"/etc/restart-services.d/00-local.conf<<-EOF
+ # You may put your local changes here or in any other *.conf file
+ # in this directory so you can leave /etc/restart-services.conf as is.
+ # Example:
+ # *extend* SV_ALWAYS to match 'myservice'
+ # SV_ALWAYS+=( myservice )
+ EOF
+}
+
+pkg_postinst() {
+ local MAJOR MINOR
+ # migrate config data for versions < 0.13.2
+ if [[ $REPLACING_VERSIONS ]]; then
+ MAJOR=${REPLACING_VERSIONS%%.*}
+ MINOR=${REPLACING_VERSIONS%.*}
+ MINOR=${MINOR#*.}
+
+ if [[ $MAJOR -eq 0 && $MINOR -lt 14 ]]; then
+ einfo "Checking for old config"
+ if [[ -f /etc/restart_services.conf ]]; then
+ ewarn "Old config file found: /etc/restart_services.conf"
+ ewarn "It will be ignored so please migrate settings to a file in"
+ ewarn "/etc/restart-services.d/ and/or remove /etc/restart_services.conf"
+ fi
+ if [[ -d /etc/restart_services.d ]]; then
+ ewarn "Old config directory found: /etc/restart_services.d"
+ ewarn "It will be ignored so please migrate files to /etc/restart-services.d"
+ ewarn "and/or remove /etc/restart_services.d"
+ fi
+ einfo "done"
+ fi
+ fi
+}