summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-05-18 00:19:18 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-05-18 00:28:25 +0200
commit35b514a4d22485c6a13b683837910370908e62fc (patch)
tree07638ae3d50f237a36e6c03a47233fba63412a9a /app-admin/rsyslog/files
parentkde-frameworks/kio: Drop 5.34.0 (r0) (diff)
downloadgentoo-35b514a4d22485c6a13b683837910370908e62fc.tar.gz
gentoo-35b514a4d22485c6a13b683837910370908e62fc.tar.bz2
gentoo-35b514a4d22485c6a13b683837910370908e62fc.zip
app-admin/rsyslog: Bump to v8.27.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-admin/rsyslog/files')
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.26.0-fix-zmq3-format-security.patch39
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-librdkafka-detection.patch43
2 files changed, 82 insertions, 0 deletions
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.26.0-fix-zmq3-format-security.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.26.0-fix-zmq3-format-security.patch
new file mode 100644
index 000000000000..b285798bfe45
--- /dev/null
+++ b/app-admin/rsyslog/files/8-stable/rsyslog-8.26.0-fix-zmq3-format-security.patch
@@ -0,0 +1,39 @@
+--- a/contrib/imzmq3/imzmq3.c
++++ b/contrib/imzmq3/imzmq3.c
+@@ -403,7 +403,7 @@ static rsRetVal createSocket(instanceConf_t* info, void** sock) {
+
+ /* Do the bind/connect... */
+ if (info->action==ACTION_CONNECT) {
+- rv = zsocket_connect(*sock, info->description);
++ rv = zsocket_connect(*sock, "%s", info->description);
+ if (rv == -1) {
+ errmsg.LogError(0,
+ RS_RET_INVALID_PARAMS,
+@@ -413,7 +413,7 @@ static rsRetVal createSocket(instanceConf_t* info, void** sock) {
+ }
+ DBGPRINTF("imzmq3: connect for %s successful\n",info->description);
+ } else {
+- rv = zsocket_bind(*sock, info->description);
++ rv = zsocket_bind(*sock, "%s", info->description);
+ if (rv == -1) {
+ errmsg.LogError(0,
+ RS_RET_INVALID_PARAMS,
+--- a/contrib/omzmq3/omzmq3.c
++++ b/contrib/omzmq3/omzmq3.c
+@@ -242,14 +242,14 @@ static rsRetVal initZMQ(instanceData* pData) {
+ if (pData->action == ACTION_BIND) {
+ /* bind asserts, so no need to test return val here
+ which isn't the greatest api -- oh well */
+- if(-1 == zsocket_bind(pData->socket, (char*)pData->description)) {
++ if(-1 == zsocket_bind(pData->socket, "%s", (char*)pData->description)) {
+ errmsg.LogError(0, RS_RET_NO_ERRCODE, "omzmq3: bind failed for %s: %s",
+ pData->description, zmq_strerror(errno));
+ ABORT_FINALIZE(RS_RET_NO_ERRCODE);
+ }
+ DBGPRINTF("omzmq3: bind to %s successful\n",pData->description);
+ } else {
+- if(-1 == zsocket_connect(pData->socket, (char*)pData->description)) {
++ if(-1 == zsocket_connect(pData->socket, "%s", (char*)pData->description)) {
+ errmsg.LogError(0, RS_RET_NO_ERRCODE, "omzmq3: connect failed for %s: %s",
+ pData->description, zmq_strerror(errno));
+ ABORT_FINALIZE(RS_RET_NO_ERRCODE);
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-librdkafka-detection.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-librdkafka-detection.patch
new file mode 100644
index 000000000000..366c0afaca84
--- /dev/null
+++ b/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-librdkafka-detection.patch
@@ -0,0 +1,43 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1695,12 +1695,14 @@ AM_CONDITIONAL(ENABLE_KAFKA_TESTS, test x$enable_kafka_tests = xyes)
+
+ # omkafka works with older library
+ if test "x$enable_omkafka" = "xyes"; then
+- PKG_CHECK_MODULES([LIBRDKAFKA], [librdkafka],, [
+- AC_CHECK_LIB([rdkafka], [rd_kafka_produce], [
+- AC_MSG_WARN([librdkafka is missing but library present, using -lrdkafka])
+- LIBRDKAFKA_LIBS=-lrdkafka
+- ], [
+- AC_MSG_ERROR([could not find rdkafka library])
++ PKG_CHECK_MODULES([LIBRDKAFKA], [rdkafka],, [
++ PKG_CHECK_MODULES([LIBRDKAFKA], [librdkafka],, [
++ AC_CHECK_LIB([rdkafka], [rd_kafka_produce], [
++ AC_MSG_WARN([librdkafka is missing but library present, using -lrdkafka])
++ LIBRDKAFKA_LIBS=-lrdkafka
++ ], [
++ AC_MSG_ERROR([could not find rdkafka library])
++ ])
+ ])
+ ])
+ AC_CHECK_HEADERS([librdkafka/rdkafka.h])
+@@ -1708,12 +1710,13 @@ fi
+
+ # imkafka needs newer library
+ if test "x$enable_imkafka" = "xyes"; then
+- PKG_CHECK_MODULES(LIBRDKAFKA, rdkafka >= 0.9.1)
+- AC_CHECK_LIB([rdkafka], [rd_kafka_produce], [
+- AC_MSG_WARN([librdkafka is missing but library present, using -lrdkafka])
+- LIBRDKAFKA_LIBS=-lrdkafka
+- ], [
+- AC_MSG_ERROR([could not find rdkafka library])
++ PKG_CHECK_MODULES([LIBRDKAFKA], [rdkafka >= 0.9.1],, [
++ AC_CHECK_LIB([rdkafka], [rd_kafka_produce], [
++ AC_MSG_WARN([librdkafka is missing but library present, using -lrdkafka])
++ LIBRDKAFKA_LIBS=-lrdkafka
++ ], [
++ AC_MSG_ERROR([could not find rdkafka library])
++ ])
+ ])
+ AC_CHECK_HEADERS([librdkafka/rdkafka.h])
+ fi