summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-07 16:26:06 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-07 16:26:06 -0500
commit11bf36377f51303256cc2b4d363b147dfda80bea (patch)
tree934a03b83b2155db223c3f5930a68f676b60a438 /app-admin/sagan/files
parentapp-crypt/dieharder: fix random on 64bit (diff)
downloadgentoo-11bf36377f51303256cc2b4d363b147dfda80bea.tar.gz
gentoo-11bf36377f51303256cc2b4d363b147dfda80bea.tar.bz2
gentoo-11bf36377f51303256cc2b4d363b147dfda80bea.zip
app-admin/sagan: Fix mysql dependencies
Bug: https://bugs.gentoo.org/665814 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'app-admin/sagan/files')
-rw-r--r--app-admin/sagan/files/mysql_check.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-admin/sagan/files/mysql_check.patch b/app-admin/sagan/files/mysql_check.patch
index d2247aab571e..37f7d61fa0c8 100644
--- a/app-admin/sagan/files/mysql_check.patch
+++ b/app-admin/sagan/files/mysql_check.patch
@@ -16,8 +16,8 @@ rename to configure.ac
- AC_CHECK_LIB(mysqlclient_r, main,,AC_MSG_ERROR(The MySQL library libmysqlclient_r is missing!
-If you're not interested in MySQL support use the --disable-mysql flag.))
- fi
-+ LIBS=$(mysql_config --libs_r)
-+ AC_CHECK_LIB(mysqlclient_r, main,,AC_MSG_ERROR(The MySQL library libmysqlclient_r is missing!))
++ LIBS=$(mysql_config --libs)
++ AC_CHECK_LIB(mysqlclient, main,,AC_MSG_ERROR(The MySQL library libmysqlclient is missing!))
+fi
+LIBS="$save_LIBS $LIBS"
+