summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-10-13 15:12:44 +0800
committerIan Delaney <idella4@gentoo.org>2015-10-13 15:13:49 +0800
commit2ef0fbb716790037c8d7eeb48a475478a213bcfb (patch)
treed8ba7900b30148ce64c697b2bedb92379afd5f09 /app-admin/sagan/files
parentsys-fs/eudev: restore keywords for alpha and ia64. (diff)
downloadgentoo-2ef0fbb716790037c8d7eeb48a475478a213bcfb.tar.gz
gentoo-2ef0fbb716790037c8d7eeb48a475478a213bcfb.tar.bz2
gentoo-2ef0fbb716790037c8d7eeb48a475478a213bcfb.zip
app-admin/sagan: patch added to correct location of header liblognorm.h
patch added via gentoo bug thanks to 'whissi', added (for now) as co-manitainer in metadata. Gentoo bug: #558154 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-admin/sagan/files')
-rw-r--r--app-admin/sagan/files/sagan-1.0.0-liblognorm-json-c.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/sagan/files/sagan-1.0.0-liblognorm-json-c.patch b/app-admin/sagan/files/sagan-1.0.0-liblognorm-json-c.patch
new file mode 100644
index 000000000000..f9540652717a
--- /dev/null
+++ b/app-admin/sagan/files/sagan-1.0.0-liblognorm-json-c.patch
@@ -0,0 +1,55 @@
+diff -rupN old/sagan-1.0.0RC3/configure.ac new/sagan-1.0.0RC3/configure.ac
+--- old/sagan-1.0.0RC3/configure.ac 2014-06-16 22:23:22.000000000 +0200
++++ new/sagan-1.0.0RC3/configure.ac 2015-10-11 21:04:26.493632624 +0200
+@@ -192,29 +192,15 @@ If you're not interested in libesmtp sup
+ fi
+
+ if test "$LOGNORM" = "yes"; then
+- AC_MSG_RESULT([------- liblognorm support is enabled -------])
+- AC_CHECK_HEADER([liblognorm.h])
+- AC_CHECK_HEADERS([json/json.h json.h], [break], [AC_MSG_ERROR([json-c headers not found or not usable.
+-This library is important for the correlation aspects of Sagan! Please see
+-https://wiki.quadrantsec.com/bin/view/Main/LibLogNorm. To disable this feature
+-use the --disable-lognorm flag.])])
+- AC_CHECK_LIB(estr, main,,AC_MSG_ERROR(The libestr library cannot be found.
+-This library is important for the correlation aspects of Sagan! Please see
+-https://wiki.quadrantsec.com/bin/view/Main/LibLogNorm. To disable this feature
+-use the --disable-lognorm flag. ))
+- AC_CHECK_LIB(ee, main,,AC_MSG_ERROR(The libee library cannot be found.
+-This library is important for the correlation aspects of Sagan! Please see
+-https://wiki.quadrantsec.com/bin/view/Main/LibLogNorm. To disable this feature
+-use the --disable-lognorm flag. ))
+- AC_CHECK_LIB(lognorm, main,,AC_MSG_ERROR(The liblognorm library cannot be found.
+-This library is important for the correlation aspects of Sagan! Please see
+-https://wiki.quadrantsec.com/bin/view/Main/LibLogNorm. To disable this feature
+-use the --disable-lognorm flag. ))
+- AC_CHECK_LIB(json, json_object_put,, [ AC_CHECK_LIB(json-c, json_object_put,,AC_MSG_ERROR(The json library cannot be found.
+-This library is important for the correlation aspects of Sagan! Please see
+-https://wiki.quadrantsec.com/bin/view/Main/LibLogNorm. To disable this feature
+-use the --disable-lognorm flag.)) ],)
+- fi
++ AC_MSG_RESULT([------- liblognorm support is enabled -------])
++
++ PKG_CHECK_MODULES(LIBEE, libee >= 0.3.2)
++ PKG_CHECK_MODULES(LIBESTR, libestr >= 0.1.9)
++ PKG_CHECK_MODULES([JSON_C], [json-c],, [
++ PKG_CHECK_MODULES([JSON_C], [json],,)
++ ])
++ PKG_CHECK_MODULES(LIBLOGNORM, lognorm >= 1.0.2)
++fi
+
+ if test "$LIBPCAP" = "yes"; then
+ AC_MSG_RESULT([------- libpcap support is enabled -------])
+diff -rupN old/sagan-1.0.0RC3/src/Makefile.am new/sagan-1.0.0RC3/src/Makefile.am
+--- old/sagan-1.0.0RC3/src/Makefile.am 2014-06-16 22:23:22.000000000 +0200
++++ new/sagan-1.0.0RC3/src/Makefile.am 2015-10-11 21:05:28.754492699 +0200
+@@ -2,6 +2,9 @@ AUTOMAKE_OPIONS=foreign no-dependencies
+
+ bin_PROGRAMS = sagan
+
++sagan_CFLAGS = $(JSON_C_CFLAGS) $(LIBESTR_CFLAGS) $(LIBLOGNORM_CFLAGS)
++sagan_LDFLAGS = $(JSON_C_LIBS) $(LIBESTR_LIBS) $(LIBLOGNORM_LIBS)
++
+ sagan_SOURCES = sagan.c \
+ sagan-classifications.c \
+ sagan-config.c \