summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-05-05 01:36:41 +0800
committerJason Zaman <perfinion@gentoo.org>2016-05-05 01:37:28 +0800
commit1accd9e118f772c3034d56ecdef10631d8af564a (patch)
tree5d608ce33bf0355558652c0a27cdc20b68684354 /app-admin/setools/setools-9999.ebuild
parentdev-lang/php: version bump all three series with security fixes. (diff)
downloadgentoo-1accd9e118f772c3034d56ecdef10631d8af564a.tar.gz
gentoo-1accd9e118f772c3034d56ecdef10631d8af564a.tar.bz2
gentoo-1accd9e118f772c3034d56ecdef10631d8af564a.zip
app-admin/setools: bump to 4.0.0 and drop keywords for testing
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-admin/setools/setools-9999.ebuild')
-rw-r--r--app-admin/setools/setools-9999.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/app-admin/setools/setools-9999.ebuild b/app-admin/setools/setools-9999.ebuild
index 5019032d666f..4a0694a4689d 100644
--- a/app-admin/setools/setools-9999.ebuild
+++ b/app-admin/setools/setools-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-PYTHON_COMPAT=( python2_7 python3_4 )
+EAPI="6"
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
inherit distutils-r1
@@ -14,20 +14,23 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/TresysTechnology/setools.git"
else
- #SRC_URI="https://github.com/TresysTechnology/setools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/TresysTechnology/setools/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="debug test"
+IUSE="X debug test"
RDEPEND="${PYTHON_DEPS}
>=sys-libs/libselinux-2.4:=[${PYTHON_USEDEP}]
>=dev-python/networkx-1.8[${PYTHON_USEDEP}]
app-arch/bzip2:=
dev-libs/libpcre:=
- "
+ X? (
+ dev-python/PyQt5
+ dev-qt/qtchooser
+ )"
DEPEND="${RDEPEND}
>=dev-lang/swig-2.0.12:0
@@ -41,5 +44,11 @@ DEPEND="${RDEPEND}
python_prepare_all() {
sed -i "s/'-Werror', //" "${S}"/setup.py || die "failed to remove Werror"
+
+ use X || local PATCHES=( "${FILESDIR}"/setools-4.0.0-remove-gui.patch )
distutils-r1_python_prepare_all
}
+
+python_test() {
+ esetup.py test
+}