summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/socklog/socklog-2.1.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/socklog/socklog-2.1.0.ebuild')
-rw-r--r--app-admin/socklog/socklog-2.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/socklog/socklog-2.1.0.ebuild b/app-admin/socklog/socklog-2.1.0.ebuild
new file mode 100644
index 000000000000..2a024b297795
--- /dev/null
+++ b/app-admin/socklog/socklog-2.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="small secure replacement for syslogd with automatic log rotation"
+HOMEPAGE="http://smarden.org/socklog/"
+SRC_URI="http://smarden.org/socklog/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static"
+
+RDEPEND=">=sys-process/runit-1.4.0"
+
+S=${WORKDIR}/admin/${P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.0-headers.patch
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ dobin tryto uncat socklog-check || die
+ dosbin socklog socklog-conf || die
+
+ cd ..
+ dodoc package/CHANGES
+ dohtml doc/*.html
+ doman man/*
+}